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PART I - INTRODUCTION 
 
1. INTRODUCTION 
 
Thank you for purchasing PUPPY STUFF. In this document you will find instructions for 
use of the program. PUPPY STUFF is very easy to use, if you are familiar with other 
windows programs you will feel right at home. If you don’t know much about computers 
you will be amazed at how easy it really is. This User’s Manual should contain about 
anything you want to know about what you can do in the program. But please feel free 
to contact us should you have any questions. 
 
This program was designed for Pet Shops who need to keep accurate, up to date 
records. The forms you use in this program contain all of the information required by 
APRI, AKC, USDA, State agencies and more. I hope you like the program and I always 
appreciate input from users of the programs. Please feel free to call, fax or send 
comments or questions to me at the address on the cover of this book. (also in the back 
of the book) 
 
2. COPYRIGHT NOTICE 
 
PUPPY STUFF and this document are copyrighted. 
This software is owned by Stacy L. Chapman, dba Chapman Pet Programs and is 
protected by United States Copyright laws and international treaty provisions. You may 
not reverse engineer, decompile, disassemble, or create derivative works from the 
software. 
 
3. LICENSE AGREEMENT 
 
You are permitted to use this program on up to 3 computers, to maintain records for 
one Owner/Business.  Ownership of this program is not transferable. When using 
an upgrade the ownership of all previous versions must also be retained.  
 
4. DISCLAIMER  
 
THIS SOFTWARE AND MANUAL ARE PROVIDED  
“AS-IS”. I disclaim all warranties relating to this software or manual, whether 
express or implied, including without limitation any implied warranties of 
merchantability or fitness for a particular purpose. I will not be liable for any 
incidental, consequential, indirect or similar damages due to loss of data or any 
other reason. The user assumes the entire risk as to the accuracy and use of this 
product. This agreement shall be governed by the laws of the State of Illinois, and 
any legal action brought in a State or Federal Court of competent jurisdiction 
located in Adams County, Illinois. The parties hereby consent to jurisdiction of 
said courts. 
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I AM NOT RESPONSIBLE FOR LOST DATA. You should make regular back-ups of 
your data. See the “Back-ups” section of this book.   
 
5. LIMITED WARRANTY 
 
To the registered User only, Chapman Pet Programs provides the following warranty: 
For a period of ninety (90) days from the date of purchase, as is evidenced by a copy of 
your receipt, that: (1.)The Software, unless modified, will perform substantially the 
functions described in the owners manual provided by Chapman Pet Programs. 
(2.) The Software media provided will be free from defects in material and workmanship 
under normal use. 
  
6. ASSUMPTIONS 
 
This book assumes that you are familiar with the windows operating system that you 
are using. We will try to explain the use of features in the program as best we can, but 
it is your responsibility to know how to run windows. 
 
 
PART II – INSTALLATION & SYSTEM REQUIREMENTS 
 
1. SYSTEM REQUIREMENTS 
 
This program requires an IBM compatible Pentium PC or higher computer with a 
minimum of 24MB of RAM, a hard drive with at least 15M of free space, Windows 95, 
98, ME or above, a Mouse and a CDROM drive.   
 
2. INSTALLATION 
 
 1. Start your computer 
 2. Insert the CD, If installation does not start automatically continue with step 3. 
 3. Click on the START button and select RUN 

4. Type X:\Setup in the Command line Box (Replace the X with your CDROM 
drive letter) 

 5. Choose the OK button 
 6. Follow the On Screen instructions 
 7. Read the Y2K COMPATABILITY NOTICE on page 8.  

NECESSARY EVEN IN NEW PC’s 
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!!!!!!!!!   Y2K COMPATABILITY NOTICE:   !!!!!!!!!!!! 
This program is Y2K compatible provided you make one of the following changes. 
 
1. THE OK SOLUTION: 
When entering dates for the year 2000 or above it is necessary to enter all 4 digits of 
the year such as 2000 rather than just the 00. Entering 00 will actually store the date as 
1900. The easiest way to know that the correct date is being entered is to make sure 
that you have changed your computer’s short date format so that you will be able to see 
all 4 digits of the year. This is done by going to: Start, Settings, Control Panel, 
Regional Settings, select the Date tab in the Regional Settings. Change the Short 
Date Format there to m/d/yyyy. 
 
OR 
2. THE BEST SOLUTION: 
Many people find it annoying to have to enter all 4 digits of the year.  
Microsoft has come out with a fix for this problem for Access 2.0 forms, So that entry of 
just the 00 is recorded correctly as 2000. This program uses many Access 2.0 forms 
and databases. We do not have permission to distribute the files to fix this problem but 
you can download them free from the Microsoft web site. The files and instructions are 
contained in their knowledge base article Q231408.  The instructions they give are for 
modifying files in the C:\Access folder but you will need to modify the files in the 
C:\pupystuf folder instead. Be sure to print the entire article as following the precise 
instructions they give is very important to changing the way the dates work. It does 
work like a charm. We have installed it on a number of computers. We are not allowed 
to distribute these files so we do not support these files or offer directions for 
getting them properly downloaded and installed.   Go to: www.microsoft.com and do a 
search for the article. 
 
We can offer some assistance in letting you know that the updated files in the fix 
are installed with this program. This means that it may be possible that you only 
need to complete the instructions below to make the changes. However if the files 
have also been installed in other folders on your computer by other programs you may 
need to download the complete fix and follow all of the instructions that come with it.   
 
*Open the C:\Windows\Win.ini file in any text editor, such as Notepad. 
*Scroll down to the end of the Win.ini file, and then type the following lines at the end of 
the Win.ini file: 
 
[Microsoft Access 2.0] 
TwoDigitYearMax=2029 
 
Save the changes by choosing Save from the File menu and then close the file and 
Restart your computer. IMPORTANT: These lines must be entered exactly as shown.  
If they are not PUPPY STUFF will assume that the two-digit years fall within the 1900s. 
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PART III - PROGRAM BASICS 
 
1. DEFINITIONS 
Here are a few common definitions. For more information, buy a computer 
dictionary, also the Windows for Dummies Books are very good. 
 
It is important to know a few computer terms so that you can correctly identify 
things on your screen.  This is extremely helpful (and saves you money) if you are 
going to telephone someone for help with a problem and they are not able to see your 
computer! Phone time can be reduced drastically. It is also helpful if you relay exact 
problems by writing down messages that appear and exactly what happened or what 
you were doing when you had the problem.  
 
*Active Window - the window on your desktop that has the focus, usually the one on 
top of (covering) the other windows. 
*Click - Press the left mouse button and release 1 time 
*Clipboard - an invisible place in your computer that holds things for you until you 
need them or replace them with something else. 
*Current Record - The record that is visible on the form, or the record your cursor is in. 
*Cursor - The little ” I “ line that blinks to let you know where you are on the screen. 
*Desktop - The background area of your screen. 
*Dialog Box - A small form that pops up with available choices for various tasks. 
*Field - A box or place designed for a particular piece of information. 
*Field Selector - The gray bar at the top of a column in a datasheet. 
*Form - A screen or Window where you view or edit information. 
*Icon - A small square with a picture on it, usually found on your desktop. When you 
doubleclick an icon it usually opens a program. 
*Menu – A list of options. 
*Menubar - the row of words along the top of the window containing words like File, 
Edit, View... (when you click on one it opens a menu) 
*Navigation Bar - The small bar at the bottom right corner of a form window, containing 
4 buttons and Record x of x. 
*Re-Boot- Simply means to shut the computer off and turn it back on. 
*Reformat a Computer – This is when you erase all data, programs and settings from 
the hard drive and usually includes reinstalling them as it was when new.  
*Record Selector - The gray block on the left side of a record in a form. 
*Required Data – Means data must be entered in a specified field in order to continue 
or to save the record. 
*Right-Click – To click with the right mouse button, rather than the left button. 
*Selection – The highlighted text or records. Can also be the current record. 
*Subform - A form within a form. Such as a vaccination record on a litter record. 
*Title Bar - The colored bar across the top of a window that usually tells you what 
window you are looking at. 
*Unique – One of a kind or only used once. 
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2. MENUBAR COMMANDS 
 
Not all of the commands on the menubar are available for all of the FORMS.  
You will probably use the buttons on the Forms rather than the Menubar for the basic 
functions in the program. 
The Menubar that is displayed through most of the program looks like this. 
 
File     Edit     View     Format     Records 
 
The Menubar is located at the top left side of your screen. 
The Menubar for the Main Menu only has a simplified  File menu. 
Following is a brief explanation of each command available from the menubar. 
 

File 
 
Close - Closes the active window, (usually the one on top) 
 
Save Record - Saves changes you have made to the current record. Note: Record 
changes are saved automatically when you move to a different record or close a form. 
 
Output To - Opens a dialog box for selecting options for copying records into various 
other file formats. See Part XI of the User’s manual for more detail on this option. 
 
Import - Opens a dialog box for selecting Import options. See Part XI of the User’s 
manual for more detail on this option. 
 
Export - Opens a dialog box for selecting Export options. See Part XI of the User’s 
manual for more detail on this option. 
 
Print Setup - Opens the Print Setup dialog box where you choose various printing 
options. See Part V, Printing, in the User’s Manual. 
 
Print Preview - Opens the print preview window to show you what the current form or 
report will look like when printed. See Part V, Printing, in the User’s Manual. 
 
Print -  Opens the Print Dialog box to select print options. See Part V, Printing, in the 
Users Manual. 
 
Exit - Exits the PUPPY STUFF program. 
 

Edit 
 
Undo - Use this command to undo the last thing you done. You may also press the 
ESC key 1 time to undo changes in a single field or 2 times to undo changes in an 
entire record. 
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Cut - Remove the selected text or record and puts it on the invisible clipboard. 
 
Copy - Makes a copy of the selected text or record (highlighted) and puts it on the 
clipboard. 
 
Paste - Puts a copy of whatever is on the invisible clipboard into the field where you 
have your cursor. When pasting an entire record you must first choose Edit, Select 
record and then Edit, Paste. 
 
Delete - Deletes the current field, the selected text or the selected record. 
 
Select Record - Selects the current record so that you may print it, delete it or Paste 
another record into it. Records can also be selected by clicking on the gray bar to the 
left of the record if it is available. 
 
Select all Records - Selects all of the records in the current form so you may print, 
delete them or whatever. 
 
Find - Opens the Find Dialog box used to do a search. You may also open this Dialog 
box by pressing the “ F7” key on the keyboard. For more information, see P.21  
 
Replace - Opens the Replace Dialog box. You may also open this dialog box by 
pressing (Shift + “F7”) For more information, see P.22  
 

View 
 
Form - View the current form in Form View. 
 
Datasheet - View the current Form in Datasheet View. (Rows and Columns of data) 
 

Format 
(The Format commands are only available in Datasheet View) 

 
Font -Opens a dialog box to change the Font properties. 
 
Row Height - Opens a dialog box to change the Row Height. 
 
Column Width - Opens a dialog box to change the column width.  
 
Hide Columns - Hides the selected columns. 
 
Show Columns - Opens a list of all available columns for you to select which ones you 
want to be visible. 
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Freeze Columns - Freezes Selected columns so that when you scroll across the 
datasheet these columns will remain in view. 
 
Unfreeze All Columns - Does just that. 
 
Gridlines - Toggles the gridlines of the datasheet Off/On. 
 

Records 
 

GoTo - Offers you a choice of going to the First, Last, Next, Previous, or a New 
record in the current Form. 
 
Refresh - Refreshes the form to show any changes or to do recalculations of any 
calculated field. 
 
Quick Sort - Allows you to sort the records in the current form in Ascending or 
Descending order according to the field that your cursor is in when you choose this 
command. 
 
Show All Records - Use this command to view all of the records if a filter has been 
applied and some records are not included. 
 

Window 
 

Tile – Tiles all open windows. 
 
Cascade – Stacks all open windows so that the title bars are visible. 
 
Lists all open windows 
 
 
3. NAVIGATION 
(See optional techniques in the “HOT KEYS” section) 
 
FROM FIELD TO FIELD IN A RECORD 
 
All of the forms have a preset Tab order. The cursor blinks in the field that you are in. 
Press enter or Tab to move to the next field, or use your mouse to select the field you 
wish to move to by clicking on it. In some of the fields with more than one line of text 
possible, the enter key will move to the next line in the same field. Use the tab key to 
leave those fields. In some cases you may use the arrow keys to move from field to 
field. 
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FROM RECORD TO RECORD IN A FORM 
 
To move from one record to another, you may use several methods. 
*At the bottom of some of the forms there is a bar with buttons on the bottom left side of 
the form window that looks like the diagram below. This is called the navigation bar. 
When available you may use this method of moving from record to record.  
 
This Button moves you to the first record in the form. 
 This Button moves you to the previous record. 
       This is the number of the current record. 
         This is the total number of records available. 
     This Button moves you to the next record. 
            This button moves you to the last record. 
 
<I < Record 1 of 3 > I> 

  
             By changing the record number here, you will automatically move 
to the record corresponding to the number that you enter. 
 
*You may use the GoTo command on the Records Menu. 
*You may use the Find command on the Edit Menu. 
*In some forms you may use a “Go To” List available at the top of the form to select the 
desired record to go to.  
*On some forms we have added buttons at the top of the form to move to the next or 
previous record. 
*Using the Page down or Page up keys on the keyboard will move you to the bottom or 
top of a form or to the next or previous record. 
 
4. ENTERING AND EDITING DATA 
 
*Not all forms allow entering or editing, some of them are for viewing or printing only, in 
these forms you will not be able to edit or enter any information. These types of forms 
take data from other records in the program. See Part VII, Specific Forms  for 
information about which forms allow entering or editing of records. 
 
*In the forms that allow you to enter or edit data, you may also enter or edit data in the 
Datasheet View when available. This is sometimes handy when you want to change the 
same particular field in each record quickly, as it would be like just going down a list. 
 
To enter a new record in a form you must first go to a new record in one of the 
following ways. 
 
1.)Choose GoTo/New from the records menu. 
2.) Click the “NEW” button on the form (if available). 
3.) Scroll to the last record and click the next record button on the navigation bar. 
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4.) Move to the record with an( *) in the record selector bar at the bottom of a datasheet 
view , or in a subform of a Form. 
  
Once in a new record, simply enter the desired info.  
 
A new or edited record is automatically saved when you move to a different record or 
close the form. You will receive a message if there is a reason the record can’t be 
saved. For example if you have entered an Id# or Reg. # that has already been used. 
You may also select “Save Record” from the “File” Menu to update related records that 
may be opened by pressing a button on the current form. 
 
To edit a record, simply go to the record you would like to modify and make any  
desired changes.  
The changes you have made will automatically be saved when you move to another 
record or close the form. If you change your mind before the record is saved you may 
press ESC to back out of the changes in a field or press ESC 2 times to undo all 
changes made to the record. 
You may also select “Save Record” from the “File” Menu to update related records that 
may be opened by pressing a button on the current form. 
  
In the fields that contain a dropdown list, you can begin typing until the desired entry 
appears, this is called quickfill or click the arrow key at the right end of the field (or 
press “F4”) to display a list of available entries. Click the one you want from the list or 
hit enter when the quickfill matches the entry you want.  In some of the list fields you 
may type in what you want even if it is not in the list, and some of them require you to 
choose an entry from the list. 
 
To sort records in a form, select the field you want to sort. (just click in the field) In a 
datasheet click in, or select the column or columns you want to sort and then Choose 
Quick Sort from the Records menu, and then choose Ascending or Descending. 
 
To Select a record choose Edit, Select Record from the Menubar or in datasheets and 
in some forms you can click the gray bar to the left of the record to select it.  For more 
info on selecting data and records for various reasons see P.xxxxxxx 
 
To delete a records in a form or datasheet select the record or records you want to 
delete then from the Edit menu, choose Delete (or press the DEL key). If you don’t 
select the record first you will just be deleting data from the visible fileds and a blank 
record will still be there and you could get a message that certain fields are required. 
Press ESC 2 times to put the record back as it was and then select the record as 
described above and then Delete it. If you are entering a new record that has not been 
saved yet and change your mind just Press Esc 2 times to back out of it rather than 
delete it. 
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To Copy and Paste a record  
 
To copy a record 
1.) Open the form and record that contains the data you would like to copy. 
2.) Click on Edit, Select Record from the menubar to select the entire record. Note:It 
may not become highlighted but it is still selected. 
3.) Click on Edit, Copy from the menubar. This copies the entire record to the invisible 
clipboard. 
 
To paste a record  
1.) Open the empty record that you would like to paste the data into. 
2.) Click on Edit, Select Record. 
3.) Click on Edit, Paste.  
 
When you paste records into a form PUPPY STUFF matches the field names of the 
underlying source table with those of the destination table and pastes each value into 
the corresponding field. You should not have any problems when pasting records back 
into another record in the same form they were copied from because the fields are the 
same.  
 
Printing records - see Page 31
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Here is a simple list of editing techniques. 
 
 

Replace an old value with a new value  With the field selected 
 type a new value 
  
Insert a value in a field Type the new value at the blinking 

insertion point 
  
Select the current field or remove the  Press F2  
selection from the current field 
 

 

Move the insertion point within a field 
 

Press ARROW keys 

Undo changes to the current field or record 
 

Press ESC 

Insert a new line character in a field 
 

Press CTRL+ENTER 

Replace the value in a field with the value of 
the same field in the previous record 

Press CTRL+" 

  
Replace the value of a field with its default 
value 

Press CTRL+ALT+SPACEBAR 

  
Open a combo box list to display choices 
 

Press ALT+DOWN ARROW 

View and edit the current field in the Zoom box  Press SHIFT + F2 
  
Save changes to the current record Move to next record 
 
 

press SHIFT+ ENTER or close the 
form or datasheet 

  
Refresh displayed records 
 

Press F9 

Requery underlying records to reflect Press SHIFT + F9 
changes  
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5. FILTERING AND SORTING DATA 
 
There are many ways to filter and sort your data in the program. You may need to 
experiment to find exactly what you like best. Here is a list of possibilities. If there is 
something you would like to do and can’t find a way to do it, call for suggestions. 
There’s always another way. 
 
FILTERING RECORDS 
 
What is a Filter? 
 
A filter is a method of removing records from a form so that you may view, edit or print 
only a certain set of related records. For instance you may click on the Available button 
on the Pet Records form to apply a filter. Thus the records in the form will change to 
include only the records for the pets that are available. 
 
There are built in filters in some of the forms. When you open a form, if not all of the 
records are displayed, Check out Part VII, Specific Forms, for information about some 
of the automatic filters applied to some of the forms. 
When not all of the records are being displayed in a form, you may choose “Show All 
Records” from the “Records” Menu to cause the form to include all of the records.  
 
SORTING RECORDS 
 
What is Sorting? 
 
When you sort records you do not change or remove any of the records displayed, you 
simply put them in a different order. 
 
Each form when open will automatically sort the records it contains into an order that is 
built into that form. You may re-order the records. 
 
For example: if you would like to see the Pet Records in order by Date of birth and see 
the oldest ones first, you would do this:  
1.) Open the Pet Records form.  
2.)In the first record you see, click anywhere in the Date of Birth field, so that your 
cursor is blinking in that field.  
3.) With your mouse, click on the “Records” menu and choose “Quick Sort” and then 
“Ascending”. 
 
This will cause your records to be re-ordered as desired. 
 
For more information read the rest of this section. You can sort records in Form or 
Datasheet View into a different order than they are usually displayed by using the 
Quick Sort command. 
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In a form, you can sort the contents of only one field at a time; in a datasheet, you can 
sort the contents of one, two or three adjacent datasheet columns in a single operation. 
If you select more than one column, PUPPY STUFF sorts records starting with the 
leftmost column. 
 
You can sort records for display in either ascending or descending order, and you can 
sort by any field on the main part of a form except one with the Memo or OLE Object 
(picture) data type. Ascending means records are sorted from A to Z and I to 10 while 
descending means from Z to A and 10 to 1. 
 
To sort records 
 
1. In a form, select the field you want to sort. (just click in the filed) In a datasheet click 
in, or select the column or columns you want to sort. 
2. Choose Quick Sort from the Records menu, and then choose Ascending or 
Descending. 
 
Sorting Two or Three Columns in a Datasheet 
 
Suppose you're viewing the Pet Records Form and you want to see the pets sorted by 
Breed. Within each Breed you want to sort records by Sex, arrange columns in the 
datasheet so that the Breed column is directly to the left of the Sex column. (For 
information on moving datasheet columns, See Part IV, Datasheet View) 
Select the Breed and Sex columns, and then click the Sort Ascending button on the 
toolbar.  PUPPY STUFF sorts records first by Breed then by Sex. Records are sorted 
by values in the Breed and within each Breed the Sex are sorted. 
 
6. SEARCH, FIND AND REPLACE 
 
To search for a particular record you have several options. 
* You may use the navigation bar buttons to simply scroll through the records. 
* You may use the “GO TO” list box at the top of the form when available to pick the 
record you would like to see. 
* Or you may want to search for a particular record according to a single field. 
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Finding Data 
 
When you want to find a specific record or find certain values within fields, you can use 
the Find command to go directly to a specific record. You can also use the Find 
command to navigate through records and find one record after another. The Find 
dialog box always stays on top of your form or datasheet until you choose the Close 
button. 
 
To make searches faster, PUPPY STUFF searches only the current field unless you 
select the All Fields option in the Find dialog box 
 
To find a specific value in a field 
 
1.Move to the field where you want to search. 
2.Choose Find from the Edit menu (or click the “F7” key on the keyboard). 
3.In the Find What box, type the value you want to find.  
4.Choose the Find First button (or press the ENTER key). 
PUPPY STUFF moves to the record (if it exists). You may have to move the Find dialog 
box out of the way to see the record. 
5.Choose the Find Next button to find the next occurrence of the specified value. 
-Or-Choose the Close button to close the dialog box. 
 
Tip: After you close the Find dialog box, you can always find the next occurrence of the 
value you most recently searched for by pressing SHIFT+F4. 
 
For Example, you get a letter from AKC requesting information concerning a puppy and 
all they provide you with is the litter number. You would do this: 
1.) Open the Pet Records form, either form. 
2.) In the First record you see, click on the Litter # field so that your cursor is blinking in 
this field (don’t change this record) 
3.) Open the “Find” dialog box, by either pressing the “F7” key or selecting “Find” from 
the “Edit” menu. 
4.) In the “Find” dialog box, enter the litter # you want to go to, (like: wp123456/01) 
5.) Select the “Find First” button or simply hit the Enter key. 
This will take you immediately to the desired record. You would close the Dialog Box as 
it will stay on top if left open. If you are in a field where there is more than one record in 
the form that contains the same information, you may open the “find” Dialog box again, 
and Select the “Find Next” button or press the Hot Key Combination (Shift + F4) to 
move to the next record which matches the criteria entered. 
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Note: In the “Find” dialog box there are options available that you may select, such as 
search for “Any Part of Field” this would allow you to for example enter part of a 
Breeder’s name and find all records that include the test you have entered.  
 
Find Options 
 
When you use the Find command, you can choose several options to tell PUPPY 
STUFF how to find the data you want. 
 
Searching in All Fields 
 
PUPPY STUFF usually searches only the current field, because it's fastest to search in 
just one field. However, if you want PUPPY STUFF to find values in any field in a form 
or datasheet, select the All Fields option in the Search In option group. 
 
Finding Text Within Fields 
 
PUPPY STUFF usually searches whole fields, not the partial contents of fields (Match 
Whole Field is the fastest type of search). If you want PUPPY STUFF to look within 
each field for certain text, select Any Part Of Field from the Where box. For example, 
you might want to find any field containing a certain word. PUPPY STUFF finds each 
occurrence of the text you specify, even if the text occurs more than once in the same 
field. 
If you know that the text you are looking for is at the beginning of a field, select Start of 
Field from the Where box to make the search faster. For example,, you may want to 
search for a certain first name at the start of a field that contains first and last names. 
 
Matching Case 
 
Usually, PUPPY STUFF searches text regardless of whether it's uppercase or 
lowercase. For example, PUPPY STUFF finds "Tom" whether you specify "tom" or 
"TOM." If you want PUPPY STUFF to find only the exact text case you type, select the 
Match Case option 
 
Finding and Replacing Data 
 
Sometimes you must make the same change to your data in several places. If you want 
PUPPY STUFF to find occurrences of specific text and replace them with different text, 
you can use the Replace command. With the Replace command, you can look at each 
occurrence of the specified text before you make the change, or you can make global 
changes. To make searches faster, PUPPY STUFF searches only the current field 
unless you select the All Fields option in the Replace dialog box (see "Find Options" 
earlier in this chapter). 
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To find and replace all occurrences of specified text 
 
1. Move to the field where you want to search and replace. 
2. From the Edit menu, choose Replace. 
3. In the Find What box, type the text you want to find. 
4. In the Replace With box, type the replacement text. 
5. Choose the Replace All button. 
PUPPY STUFF prompts you to confirm the changes you made with the Replace 
command. 
6. Choose the Close button to close the dialog box. 
 
To find and replace occurrences of specified text one at a time 
 
I.Move to the field where you want to search and replace. 
2.From the Edit menu, choose Replace. 
3. In the Find What box, type the text you want to find. 
4. In the Replace With box, type the replacement text. 
5.Choose the Find Next button. 
PUPPY STUFF moves you to the next occurrence of the text you specified and selects 
it. You may have to move the Replace dialog box out of the way to see the record. 
6.To replace the specified text and move to the next occurrence, choose the Replace 
button. PUPPY STUFF doesn't prompt you to verify that you want to change the 
contents of a single field. 
-Or-To leave the selected text as is and find the next occurrence instead, choose the 
Find Next button again. 
7.When you finish replacing, choose the Close button to close the dialog box. 
For example: if you have all of the Shelties entered in the program as Sheltie and you 
realize that they should have been entered as Shetland Sheepdogs, You would change 
the Name in the Breeds List and then to Change each pet’s breed entry, do this: 
1.) Open the Pet Records Form. 
2.) Select “Show All Records” from the “Records” menu. 
3.) Click on the Breed field in the first Record you see. 
4.) Select “Replace” from the “Edit” menu. or use the Hot Key Combination (Shift + F7) 
to open the “Replace” dialog box. Enter the word “Sheltie” as the text to Find and enter 
the words “Shetland Sheepdog” as the text to Replace it with. 
5.) Select the “Replace all” button to replace all of the Shelties with Shetland 
Sheepdog. 
 
If you need more information on how to use these features you can call me for help.   
 
Using Wildcard Characters 
 
When you use the Find and Replace commands, you may not always know exactly 
what you are searching for. For flexibility, you can use the question mark (?), the 
asterisk (*), and the number sign (#) as wildcard characters in the Find What box in 
either the Find or Replace dialog box. 
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A question mark stands for any single character in the same position as the question 
mark. An asterisk stands for any number of characters in the same position as the 
asterisk. A number sign stands for a single numeric digit in the same position as that 
numeric digit (useful when you want to find a number, but not a letter). 
 
You can use characters in square brackets to find one of several characters. For 
example, to find the letter Q or X' type [QX]in the Find What box. You can indicate 
ranges of characters with a hyphen. For example, to find any letter between A and Z, 
type [A-Z]. You can specify characters you don't want to find by including an 
exclamation point (!) after the first bracket. For example, to find all characters except 
the letter M, type [!M]. 
 
The following examples illustrate the use of wildcard characters. 
 If you search for         PUPPY STUFF finds 
 Sm?th                    Smith 
                     Smyth 
 
 L*ng                    Ling 
                     Leveling 
                     Leka Travel and Trading 
 #th                    5th 
                     8th 
 
 *th                    128th 
                     Perth 
 
 Paul[ao]                    Paula 
                     Paulo 
 
 Paul[!ao]                    Pauli (but not Paula or Paulo) 
Note If you want to find one of the wildcard characters itself, enclose it in square 
brackets. For example, to find the value "#1", type [#]1. 
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7. HOT KEYS & ACCELERATOR KEYS 
 

HOT KEYS 
TAB, RIGHT ARROW 

or ENTER 
moves to the next field. Note:Sometimes the Enter key will move to 
the next line of the same field. 

SHIFT & TAB or 
 LEFT ARROW 

moves to the previous field. 

HOME moves to the first field in the current record. 
END moves to the last field in the current record. 

PAGE DOWN moves to the next record. 
PAGE UP moves to the previous record. 

Ctrl & + moves to a new record. 
Ctrl & - deletes the current record. 

Shift & Enter save changes to current record. 
F4 or  

Alt & DOWN ARROW 
drops down the list for the current field, if available. 

 NOTE: use the up and down arrows to move within a drop 
down list and the tab to close the list and go to the next field. 

Ctrl & ; inserts the current date. 
Ctrl & ‘  

or Ctrl & “ 
copies the value from the same field in the previous record. 

F7 or 
Ctrl & F 

opens the Find Dialog Box 

Shift & F7 
or Ctrl & H 

opens the Replace Dialog Box 
 

Shift & F4 Find the next occurrence of the text specified in the Find or 
Replace Dialog Box AFTER THE DIALOG BOX IS CLOSED. 

 
ACCELERATOR KEYS 
Accelerator keys are used in place of the mouse click. The keys available will vary. You 
will know what keys you can use by looking for letters that are underlined on the 
menubar and the commands available from the menu bar. To use an accelerator key 
you simply hold down the “Alt” Key while pressing the Underlined letter of the 
command. 
For example to choose “Print” from the “File” Menu you would press (Alt + F) to display 
the File Menu and then (Alt+P) to display the Print Dialog box. 
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PART IV - DATASHEET VIEWS 
 
1. CHANGING TO DATASHEET VIEW 
 
To change to Datasheet view, you select View, Datasheet from the menubar. 
Not all of the forms in the program have this view available. 
When you are in a form that contains a subform, the subform fields are not displayed in 
the datasheet view of the form. To see the subform, you will need to look at the form in 
Form view.  
 
2. CUSTOMIZING DATASHEETS 
 
PUPPY STUFF provides several ways for you to change the display of a datasheet. 
You can change the width of individual columns to fit the field values they display. You 
can re-order, hide, or freeze columns. And you can change the row height and font. 
When you save or close a form, PUPPY STUFF asks if you would like to save changes 
to the form.  This includes appearance of the datasheet as well as any changes to the 
Print Setup. If you choose yes, the next time you open the datasheet, it appears just the 
way you left it. Also any print settings will be as you saved them. 
 
Changing Column Width and Order 
 
If the columns in a datasheet don't fit the field values they display, you can change the 
width of each column. Or if you want to view fields in a different order, you can easily 
rearrange datasheet columns. 
 
To change the width of a column 
 
I.) Position the mouse pointer at the right side of the field selector for the column you 
want to resize. 
2.) Drag the column border to the desired size, 
    
To resize a column to fit the data it displays 
 
*Double-click the right edge of the field selector for the column you want to resize. 
-Or- 
*From the Format menu, choose Column Width, and then choose Best Fit. 
PUPPY STUFF sizes the column to fit the column heading and the longest value 
currently displayed in the column (not necessarily the longest value stored in the field). 
 
Tip: To resize multiple columns at once, select the columns you want to resize (or the 
entire datasheet), then drag or double-click the right edge of any one of the field 
selectors. PUPPY STUFF sizes all the selected columns to fit the data displayed. 
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To move a column 
 
I. Select the column you want to move by clicking the field selector. To select more than 
one column at a time, hold down the SHIFT key and click the other column(s) you want 
to select 
 
2. Click the field selector again and drag the column to its new position. As you drag 
the column its destination is indicated by a solid bar between columns. 
   
Hiding and Showing Columns 
 
Since you often have more fields in form or datasheet than can fit on a page, you might 
want to hide certain columns. For example, you might want to hide a customer address 
field that's too wide so you can view  or print just the Customer Name and Phone 
Number fields. 
 
To hide a column in a datasheet 
 
I. Select the column you want to hide by clicking its field selector. 
2. From the Format menu, choose Hide Columns. 
 
To show hidden columns in a datasheet 
 
1. From the Format menu, choose Show Columns. 
2. Select the column(s) you want to show, and then choose the Show button. 
3. Choose the Close button. 
 
 
Freezing and Unfreezing Columns 
 
If you want one or more fields to be visible at all times, you can freeze the datasheet 
columns on the left side of the datasheet. When you scroll through a datasheet 
horizontally to view columns to the right, frozen columns remain visible on the left. For 
example, you might want a Pet’s Breed and Sex to remain visible even when you scroll 
through the datasheet to see other fields. 
  
To freeze a column in a datasheet 
 
1. Select the column you want to freeze by clicking its field selector. 
To select more than one column at a time, hold down the SHIFT key and click the other 
column(s) you want to select. 
2. From the Format menu, choose Freeze Columns. 
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To unfreeze all columns 
 
From the Format menu, choose Unfreeze All Columns. 
 
Changing the Font or Row Height of a Datasheet 
 
You can choose any font or font size in a datasheet. If the field values don't fit in the 
columns of a datasheet, you can change the row height to display more than one line of 
text in each row. Changes to font or row height affect the whole datasheet, not 
individual rows. 
 
To change the font of a datasheet 
 
1. From the Format menu, choose Font, 
2. Select the font, style, and size you want, and then choose OK. 
 
To change the row height of a datasheet 
 
1. Position the pointer between two record selectors at the left side of the datasheet. 
2. Drag the row to the desired size. 
All rows in the datasheet change to the new row height. 
 
3. EDITING DATASHEET RECORDS 
 
Copying, Moving, or Deleting Data 
 
You may often want to copy or move data in your PUPPY STUFF database. If you use 
other applications for Windows, such as Microsoft Excel or Microsoft Word for 
Windows, you may want to copy data to those applications. 
 
When you copy data, you can use the Copy command, which leaves the original data 
intact, or the Cut command, which deletes the data so you can move it elsewhere. 
Either command places the data onto the Clipboard. You can paste data from the 
Clipboard to another location. 
 
You can copy and paste data when you want to: 
 
•Copy a value from a field and paste it into another field or fields. 

 
•Copy data or records from PUPPY STUFF to another application for Windows, such 
as a spreadsheet or a word processor. 
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Selecting Data 
 
Before you can copy, move, or delete data, you must select it. You can select: 
 
•Data within a field. 
 
•Data in two or more adjacent fields in a datasheet. 
 
•Data in one or more columns in a datasheet. 
 
•One or more whole records. 
 
The following table lists keyboard techniques for selecting data or 
records. 
  
Select data in a field Move the insertion point to the start 

of Line 
 that you want to select. then hold 

down the 
 SHIFT key and move to the end of 

the 
 selection with the ARROW keys. 

 
Select or cancel the selection 
for the entire 
contents of the current field 
 

Press P2. 

Select adjacent fields in a 
datasheet 

With a field selected, hold down the 
SHIFT 

 key and press the appropriate 
ARROW key. 
 

Select the current column in a 
datasheet 
 

Press CTRL+SPACEBAR. 
 

Select the current record Press SHIFT+SPACEBAR. 
 

Select multiple records Press SHIFT+SPACEBAR, 
then SHIFT+ UP ARROW or SHIFT 
+ DOWN ARROW 
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The following table lists mouse techniques for selecting data or 
records. 
  
Select data in a field Click where you want to start 

selecting and drag across the data. 
 

Extend a selection Hold down the SHIFT key and click 
the position you want to extend to. 
 

Select the entire contents of a 
field 

In a datasheet, click the left edge of 
the field in a form, click the fields 
label. 
 

Select adjacent fields in a 
datasheet 

Click the left edge of a field and 
drag to extend the selection. 
 

Select a column in a datasheet Click the field selector at the top of 
the column you want to select. 
 

Select adjacent columns in a 
datasheet 

Click the field selector for the first 
column you want to select and drag 
to the last one. 
 

Select a record Click the record selector to the left 
of the record you want to select. 
 

Select multiple records Click the selector (gray bar on left) 
of the first record you want to select 
and drag to the last. 
 

Select all records  (datasheet 
only) 

Click the selector in the upper-left 
corner of the datasheet. 
 

 
Deleting Data 
 
After you select data in a field, you can delete it. You can also permanently delete 
entire records from your database. 
 
To delete data from one field 
 
I. Select the data you want to delete. 
2. From the Edit menu, choose Delete (or press the DEL key). 
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To delete one or more records in a form or datasheet 
 
I. Select the record or records you want to delete. 
2. From the Edit menu, choose Delete (or press the DEL key). 
 
Copying or Moving Data in a Field 
 
Copying or moving data in a field is as easy as select, copy, and paste. After you copy 
data, you can either paste it over (replace) the contents of the destination field, or 
insert it into the existing contents. If you want to replace existing data with the contents 
of the Clipboard, select the data to be replaced before you paste. 
  
 
To copy or move data from one field to another 

I. Select the data you want to copy or cut. 

2. Choose Copy from the Edit menu to copy data Or Choose Cut from the Edit menu to 
remove the data. 

 3. Move to the destination field. If you want to replace the current value of the 
destination field, select the whole field, If you want to insert text into the existing data, 
position the insertion point where you want the text to be pasted. 

4. From the Edit menu, choose Paste. 

Copying Multiple Fields 
 
With a datasheet you can copy data in more than one field or all the data in one or 
more entire columns. For example, you can select only names and phone numbers 
from a table that stores several other fields, then copy the data to another table or to 
another Windows-based application. 
 
If the source data has more fields than the destination datasheet, PUPPY STUFF 
doesn't paste the extra fields, If the destination datasheet has extra fields, PUPPY 
STUFF doesn't paste anything into them. 
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To copy data from adjacent fields or from datasheet columns 
 
I. Select the fields or columns you want to copy or cut. 
2. Choose Copy from the Edit menu to copy Or Choose Cut from the Edit menu to move 
data 
3. Select the destination field or fields, or switch to the Windows application you want 
to paste the data into and then select the destination field or fields. 
4.  From the Edit menu, choose Paste.  
 
To copy an entire record 
 
1.) Open the form and record that contains the data you would like to copy. 
2.) Click on Edit, Select Record from the menubar to select the entire record. Note:It 
may not become highlighted but it is still selected. 
3.) Click on Edit, Copy from the menubar. This copies the entire record to the invisible 
clipboard. 
 
To paste a record  
 
1.) Open the empty record that you would like to paste the data into. 
2.) Click on Edit, Select Record. 
3.) Click on Edit, Paste.  
 
When you paste records into a form in Form view, PUPPY STUFF matches the field 
names of the underlying source table with those of the destination table and pastes 
each value into the corresponding field. You should not have any problems when 
pasting records back into a record on the same form they were copied from because 
the fields are the same 
 
If the source form has fields that don't exist in the destination form, PUPPY STUFF 
asks you if you want to paste just the columns with fields that match. If the destination 
form has fields that don't exist on the source form, PUPPY STUFF doesn't paste 
anything into them. 
 
Note It is not recommended that you try to paste outside data into PUPPY STUFF.  If 
you copy data from outside PUPPY STUFF or from a table with field names or data 
types that don't match the destination, you may run into serious problems pasting them 
in. 
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Troubleshooting Paste Problems 
 
When you copy and paste records into a form or datasheet, it may not always be 
possible for PUPPY STUFF to paste all the records. PUPPY STUFF still pastes any 
records that it can. 
 
There are several reasons why a paste error can occur: 

• You tried to paste a value that's not compatible with the data type of the field. For 
example, you tried to paste a combination of letters and numbers into a field with the 
Number data type. 

• You tried to paste text that's too long for the field. The setting in the Field Size property 
determines the maximum size of a field value. Check the field in the table's Design view 
to see the setting. 

• You tried to paste a value that already exists in the destination table into the table's 
primary key or into a field that has the Indexed property set to No Duplicates. Check 
the field in the table's Design view to see the setting. 

• A value you tried to paste isn't allowed in the field, based on the settings of the 
Validation Rule, InputMask, Required, and AllowZeroLength properties. 
 
If you can determine the reason why records weren't pasted, return to the source of the 
data. Fix the data as necessary, then try to copy and paste again. 
 
Correcting Mistakes with the Undo Command 
 
PUPPY STUFF always remembers the last change you make to your data. If you type 
data incorrectly, you can tell PUPPY STUFF to undo the changes. 
 
The Edit menu contains one of two Undo commands, depending on your most recent 
change to data. For example, whenever you edit data in a field, you can undo your 
most recent change to the data by choosing Undo Typing. To undo all changes to the 
current field or record, choose Undo Current Field or Undo Current Record (or press 
the ESC key). Even after you save changes or move to another record, you can still 
undo changes to the previously edited record by choosing Undo Saved Record until 
you begin editing another record, apply or remove a filter, or switch to another window, 
your changes become permanent. 
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PART V - PRINTING 
 
1. PRINT PREVIEW 

 
You can use Print Preview to see what your form or report will look like when you print 
it. You can also get a close-up view of previewed data, seeing selected portions of text 
at a greater magnification. Using navigation buttons, you can preview page-by-page or 
move to exactly the page you want. 

 
To preview a Form or Report 
 
Open the Form or Report you want to preview. Reports are automatically opened in 
Print preview. For Forms you must open the form and then choose Print Preview from 
the File Menu. 
The first page to be printed is displayed in the Print Preview window. Although the print 
preview does not show the total number of pages to be printed you can use the buttons 
on the navigation bar at the bottom of the preview pane to move to additional pages. 
To see a close-up of preview click on the section you would like to enlarge. 
You can read the text by getting a closeup (zoomed) view of it. Once you've zoomed in, 
use the scroll bars to move to the top, bottom, or sides of the page. 
 
To move between pages 

 
Using the navigation buttons in Print Preview, you can view pages sequentially or jump 
to any page in the document. 
 
2. PRINT SETUP 
 
I.) Open the form or report 
2.) From the File menu, choose Print Setup. 
The Print Setup dialog box is displayed. 
3.) Set the appropriate printing options such as margins and spacing. You may need to 
click on the More button to see additional options for row and column spacing for forms 
such as address labels and collar slips that can be printed on a variety of label layouts. 
4.) Choose OK. 
 
 To print selected records 
 
1.) Select the records you want to print. In a form the record you are on is always 
considered the current record or you may select several records to print. 
2.) From the File menu, choose Print, the Print dialog box is displayed. 
3.) In the Print Range group, choose Selection. 
4.) Choose OK. 
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3. SELECTING A PRINTER 
 
The printer you have selected as the default in your computer will automatically be 
used unless you choose another printer. To select a printer, you choose Print Setup 
from the File menu, and select the desired printer there.  
 
PART VI - GETTING STARTED 
 
THE MOST IMPORTANT THING in using this program is that you begin by entering 
your data in the correct order. This will save you time and work and allow you to get the 
most out of the program. 
 
Below is the order in which you should begin entering your data into the program. In 
this User’s Manual you will find GENERAL INFORMATION to explain the basic 
functions used throughout the program and SPECIFIC FORM details for using the 
various forms in the program. 
 
Step 1: Open the “Store Locations” to enter the ID, Name and Address for each 
location you will be maintaining records for. 
 
Step 2: Open the “Breeds” Form and enter the breeds you will be dealing with. Delete 
the breeds you don’t need, they can be added again later if needed. Be sure that the 
spelling is the way you want it and is singular (i.e.PUG not PUGS) 
  
Step 3: Open the “Rolodexes” Form and add all records for Brokers, Employees, Vets 
and Advertising sources you currently use. 
 
Step 4: Open the “Pet Records” to begin adding pets. 
 
Once pets have been entered you may go on and explore the various Reports and 
virtually endless possibilities of the program.  See the Specific Forms section for more 
detailed information about the various forms in the program. 
 
Have fun and feel free to call me if you have any problems and can’t seem to find the 
answer in this User’s Manual. 
 

Happy Record Keeping. 
 
 
PART VII - SPECIFIC FORMS 
 
1. GENERAL INSTRUCTIONS 
 
SEE PAGES 12-14 FOR DETAILS ON ENTERING AND EDITING RECORDS 
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There are some buttons available on the forms to do things such as Close, Add record, 
Delete record... These commands are also available from the menus. The Print buttons 
on the forms usually print only the current record. Select Print from the File Menu to 
display other print options. If there is a Del or Delete button on a form it will delete the 
current record only. 
 
Following is a brief description of each form and it’s primary use. 
 
2. SPECIFIC FORMS  
 
MAIN MENU 
 
Referred to as the Main Menu, Menu screen or Menu in this book. 
 
When you open the program (by clicking on the PUPPY STUFF icon) this menu is 
automatically displayed and remains open at all times when the program is open, 
although at times it may be hidden behind the other open forms. 
 
The Main Menu is used to access all of the other forms and reports contained in the 
program. 
 
Each Button on the Main Menu is used to open a Form, Report or another selection of 
Forms or Reports. Some of the Forms also have Buttons that open other related Forms 
or Reports. 
 
To Open the various Forms or Reports, Use the mouse to point and click on the buttons 
or you may use the tab key to highlight the appropriate button and then press enter↵. 
 
By closing or minimizing open forms and reports in the program you will always end up 
back at the Main Menu. 
 
The little Door icon on the Main Menu Exits the program. 
 
PET RECORDS FORM 
 
Open the Pet Records Form by choosing the Pet Records Button from the Main Menu. 
 
The Pet Records Form is where you will be entering the basic purchase records and 
required permanent records for each pet in the program. You will also enter the regular 
sale price here. 
 
The records are sorted in ascending order by the Pet ID field, by default. To re-order 
the records see page 13. 
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The only required field in this form is The Pet ID field although we strongly suggest that 
you try to add as much information to this form as is available, keeping in mind that 
much of this information is required by law to be kept and is displayed in other forms 
and Reports. It is also necessary in various calculations and reports. Some reports and 
other forms may not function properly if important data fields have been left blank. 
 
Buttons on the Pet Records Form  
 
> Close - Closes the form 
> New - Opens a New Record 
> Available - Filters Records to display only the puppies that have  not yet been 
sold.(Note: If after choosing this button, you would like to see all of the records again, 
simply select the “Show All Records” Command from the “Records” menu.) 
> Print Record - Prints the Full Permanent record containing all  information entered 
for the selected pet. To Print All Records or a range of records, use the “Print” 
command on the “File” menu. 
> Enter Sales Rec. - Opens the Sales Record screen to enter the sales information for 
the selected pet. 
> Med. Rec. - Opens the Medical Records screen for entering the  vaccinations and 
medications and also the vet visits for the selected pet. 
 
EXPLANATION OF FIELDS (IN TAB ORDER) 
 
> Store ID: Enter the Location ID of the Store where the pet has been received. This 
Location must be from the list of available locations (previously entered in the 
“Locations” Form). 
 
> Date Purch: Enter the date the pet was received. Make sure that this date matches 
the date on the registration forms and other documents where applicable. 
 
> Broker ID: Enter the Broker ID. This must be selected from the list of available 
Brokers (previously entered in the “Brokers” Rolodex). 
 
> Pet ID: REQUIRED, Enter an ID for the Pet. You may enter an ID of up to 25 
characters including spaces, using letters or numbers or both. This ID must be unique 
(never used twice). 
 
> USDA # assigned by Broker:  Enter the USDA or ID number of the pet that was 
previously assigned by the wholesaler from whom you purchased the pet.  
 
> Sex: Enter an M for Male or an F for Female. 
 
> DOB: Enter the pets Date of Birth. 
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> Litter # : Enter the registered litter number of the pet if applicable, skip this field if the 
pet is not registerable. If that information is not yet available then you may go back and 
enter it later. 
 
> Breed: Enter the breed of the pet. This entry must be in the list of breeds (previously 
entered in the “Breeds” Form). 
 
> Color: Enter the color of the pet. If you will be printing an AKC registration transfer 
for the pet, make sure that the color is entered exactly as you want it to print on the 
transfer. 
 
> Sire: Enter the Registered name of the sire of the pet if applicable. 
 
> Sire #: Enter the registered number of the sire of the pet if applicable. 
 
> Dam: Enter the Registered name of the dam of the pet if applicable. 
 
> Dam #: Enter the registered number of the dam of the pet if applicable.  
 
> Type Reg.: Enter the type of Registration to be provided with the Pet. This does not 
have to be in the list. 
 
> Date Papers Rec.: Enter the date that you received the pets registration papers from 
the Broker. 
 
> Breeder: Enter the Name, Address ( & phone & License #  if  available) of the 
original Breeder of the Pet, this is not necessarily the same as the Broker or the person 
you received the pet from. Once you have entered a breeder, they will be added to the 
drop down list in this field to make it easy to enter the same breeder for future pet 
entries. 
 
> Purch Price: Enter the purchase price of the pet. (the amount you paid for the pet). 
 
> Crate Fee: Enter the Crate fee you paid if applicable. 
 
> Deliv Fee: Enter the delivery fee if applicable. 
 
> Shot Fee: Enter the shot fee if applicable. 
 
> Misc Charges: Enter any other applicable charges you paid for the pet, such as 
pedigree, bonuses... 
 
> Sell Price: Enter the base price you plan to charge the customer for the pet. 
 
> Memo: Enter additional information for the pet if desired. 
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Note: For handy lists of puppies, It may sometimes be the simplest to go to datasheet 
view and set it up to show the information you use most often for reference and print 
the list from there. You may save the setup of the datasheet view and use the form view 
to edit and filter records but print scratch sheets from the datasheet view. This is just an 
idea that my be useful, there are virtually unlimited ways to customize your printouts. 
 
SALES RECORD FORM 
 
Open the Sales Record form by pressing the “Enter Sales Rec.” Button on the Pet 
Records Form. The form will automatically open to the record for the Pet displayed on 
the Pet Record form.  
 
This is where you will enter the sales information for the selected pet. 
 
BUTTONS on the SALES RECORD FORM  
 
> Close - Closes the form. 
> Inv/war - Opens the Invoice/ Warranty form for the selected       
Pet.You may view or print the form. 
> AKC Transfer - Opens the AKC transfer form to the selected  Pet. You may view 
or print the transfer. 
> Cust. Med. Rec. - Opens a medical record containing  vaccination information to 
be given to the customer. You  may view or print. 
 
EXPLANATION OF FIELDS (IN TAB ORDER) 
 
> Cust ID: Enter an optional ID up to 15 characters long. 
 
> Dr. Lic.# : Enter the Customer’s Drivers license #, optional. 
 
> First Name: Enter the Customer’s First Name. 
 
> Last Name: Enter the Customer’s Last Name. 
 
> Address: Enter the Customer’s Address. 
 
> City: Enter the Customer’s City. 
 
> State: Enter the Customer’s State. 
 
> Zip: Enter the Customer’s Zip. 
 
> Home Phone: Enter the Customer’s Home Phone #. 
 
> 2nd Phone Label: Enter the name of the Customers 2nd Phone #. 
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> Phone 2: Enter the Customer’s 2nd phone #. 
 
> Adv. Source: Enter the source of advertising that attracted the customer to your 
store. 
 
> Date Died: Enter the date that the pet passed away, when this applies. 
 
> Date Sold: Enter the sale Date of the pet. 
 
> Sale Price: This is automatically displayed as entered on the pet records form. 
 
> Disc: Enter the discount amount given when applicable. 
 
> Sales Tax: Enter the amount of Sales Tax added to the price of the pet, if applicable. 
 
> Total: This total is automatically calculated. 
 
> Date papers furn.: Enter the date that the registration papers where furnished to the 
customers, where applicable. 
 
> Empl. ID: Enter the ID of the Employee in charge of the sale. 
 
MEDICAL RECORDS 
 
Open the Medical Records Form by choosing the “Med.Rec.” button on the Pet 
Records Form. 
 
This form opens to the record for the pet displayed in the Pet Records Form when you 
choose the “Med.Rec.” button. 
 
Enter Medications given and/or veterinarian visits for the selected pet in this form. Not 
all of the fields on the form are visible. when you enter information the form will shift to 
the right displaying the remainder of the fields. 
 
>Medical Record: 
 
Enter Date administered, Product administered, Administered for, Administered by, and 
a memo if desired. 
 
>Vet Exams: 
 
Enter Date examined, Reason for exam, memo, and Examined by. (Examined by field 
must be from the list of available Vets, taken from the Vet Rolodex.) 
 
This information is automatically added to the pet’s printed record. 
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When you close this form you will automatically return to the Pet Record form for the 
pet. 
 
Note: If you wish to print the vacc record for the customer, please use the “Cust. Med. 
Rec.” available from the “Sales Information” form. 
 
AVAILABLE ROLODEXES 
 
Open this screen by selecting the “ROLODEXES” button on the main menu, to view 
and select from the available rolodexes in the program. 
  
BROKERS 
 
Open the Brokers Rolodex Form by selecting the “Brokers” button on the Available 
Rolodexes screen. 
 
The Brokers Form is where you will add information about each Broker (Supplier) from 
whom you purchase pets that you will be keeping records for. 
 
The fields in this form are pretty much self explanatory. 
 
The records are sorted in ascending order by the Broker ID field by default. 
 
The only required field in the form is the Broker ID which may be up to 7 characters. 
This ID will be displayed in lists available in other forms. 
  
CUSTOMERS 
 
Open the Customers Rolodex Form by selecting the “Customers” button on the 
Available Rolodexes screen. 
 
The Customers Rolodex contains information about the Customers previously entered 
in the Pet Sales Records. You may edit the Customers records here but you may not 
add a Customer here. 
 
The records are sorted in ascending order by the customers last name by default. 
 
The “Find:” field at the top of the form allows you to select a customer and to move 
directly to that customers record. After selecting the customer, simply press enter↵.   
 
 > MAIL LABELS You may also choose the Mail Labels button to print mailing labels 
for your customers.The customers rolodex must contain an X in the mailing Labels 
field, for any customers you desire to print labels for.  
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EMPLOYEES 
 
Open the Employees Rolodex Form by selecting the “Employees” button on the 
Available Rolodexes screen. 
 
The Employees form is where you will enter information about the employees who will 
be handling and selling pets. 
This form is pretty much self explanatory also. There is only one required field. 
The records are sorted in ascending order by the Employee ID by default. 
 
The only required field is the Employee ID field, which may be up to 7 characters. This 
ID will be displayed in lists available in other forms.  
 
The “Find:” field at the top of the form allows you to select an employee and to move 
directly to that employee’s record. After selecting the employee, simply press enter↵.   
 
MISC 
 
Open the Misc. Rolodex Form by selecting the “Misc” button on the Available 
Rolodexes screen. 
 
The Misc. Form may be used for Entering other people or businesses that do not fit in 
to any of the other rolodex categories. 
 
The records are sorted in ascending order by the Business Name by default.  
 
The fields in this form are pretty much self explanatory. No fields are required in this 
form. 
 
VETS 
 
Open the Veterinarian Rolodex Form by selecting the “Vets” button on the Available 
Rolodexes screen. 
 
The Vets Rolodex Form is where you will add information about each Veterinarian that 
you use. 
 
The fields in this form are pretty much self explanatory, with only one field being 
required. 
 
The records are sorted in ascending order by the ID by default. 
 
The only required field is the ID which may be up to 7 characters. This ID will be 
displayed in lists available in other forms. 
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ADVERTISERS 
 
Open the Advertisers Rolodex Form by selecting the “Advertising” button on the 
Available Rolodexes screen. 
 
The Advertisers Rolodex Form is where you will add information about each Advertising 
Source you use. 
 
The fields in this form are pretty much self explanatory, with only one field being 
required. 
 
The records are sorted in ascending order by the Advertiser ID by default. 
 
The only required field is the Advertiser ID which may be up to 7 characters. This ID 
will be displayed in lists available in other forms. 
 
> ADVERTISERS REPORT (SEE PAGE xx) You may open the advertisers report from 
here or from the Reports screen. 
 
BREEDS and PRICES 
 
Open the Breeds Form by selecting the “Breeds and Prices” button from the main 
menu. 
The Breeds and Prices form is where you enter information about each breed of pet 
you carry in your store. You may also enter the Regular sale price and various prices 
charged by your different suppliers for each breed entered and also print price 
comparison reports from this form. 
 
Select the “Price Rept.” button to view a comparison of prices charged by brokers 
(Suppliers) for each breed.  
 
The Records are sorted in ascending order by the Breed Name by default. See 
SORTING OR REORDERING RECORDS on P.13. 
 
The only required field in this form is the Breed: (Breed Name). 
 
The “NEW” button was added just to make it easy to add new records. 
 
 
 
STORE LOCATIONS 
 
Open the Store Locations form by selecting the “Store Locations” button on the Main 
Menu. 
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This form contains 3 records if you have purchased the standard version. DO NOT 
DELETE THESE RECORDS!  You may edit these records for your store locations but 
you may not add records to this form as it is set up for use at only 3 locations per copy 
of the program (unless you have purchased additional license agreements). 
 
The records are sorted in ascending order by the Store ID by default. 
 
The only required field is the Store ID, but it is advisable that you enter all of the 
information for each location as it will be displayed on other records in the program. 
 
PETS ON ORDER 
 
Open the Pets on Order form by selecting the “Pets on Order” button from the main 
menu. 
 
The Pets on Order form is useful when ordering specific pets in advance for customers 
who have placed a deposit on the pet. 
You may also wish to track all pets ordered in advance. 
 
The fields in this form are self explanatory. 
 
The Pets on order form is sorted only by the order of entry. 
 
COLLARS 
 
Open the Collars form by selecting “Collars” from the main menu. 
 
When open you may select to print collars in one of 3 ways. Simply select the choice 
which best suits your need at the time and enter any other information asked for by the 
pop up dialog boxes. 
 
The collars print to regular 8 1/2” X 11” pages and can be cut and folded in half to slip 
into the hospital ID bracelets. 
 
REPORTS 
 
Open the Reports selection screen by selecting the “Reports” button from the main 
menu. 
 
When you select a report, you will be prompted for other information in pop up dialog 
boxes where you will enter information about what you want in the report. Simply enter 
the requested information to open the report where you may view or print it. 
 
At the time this book was written we had not completed the reporting section of the 
program and fully intended to add other reports. So don’t be suprised if there is a much 
larger selection of available reports in your program than is visible here. 



 42 
 

PART  VIII - BACK-UPS 
 
There are 2 ways to save your data, You can Back-up or Copy your data files. 
 
To Back-up: Means to use a Back-up utility to store a copy of one or more selected 
files in an alternate location as a single file with a backup name. 
 
To Copy: Means to make an exact copy of a file or files in an alternate location. This 
can be another location on your computer such as a different folder or another drive, it 
can be copied to a disk, CD-RW or other media.  
 
Sometimes it is easier to just copy a file to a disk than to make a Back-up. See the step 
by step instructions in this section for copying your data files to a disk. 
 
Here are some general tips about making back-ups or copies of your data: 

o Make backup copies on a regular basis. Consider using automatic backup 
software. 

o Keep backup copies of your data off-site in case of a fire, flood, or other natural 
disaster. 

o Protect your backup copies by encrypting the files or locking up the tapes or 
disks. 

o Restore and read your backup copies periodically to ensure that your backup 
mechanism is working properly. 

o Maintain more than one backup copy in case both the original data and the 
backup are destroyed. 

 
How often you should back up or copy your data files depends primarily on how often 
the files are updated. For example, if you're the only person who uses your database 
and you add only a few records each day, it may be sufficient to back it up once a 
week. 
Just ask yourself if it is easier to backup or re-enter anything you stand to loose. 
 
1. FILES THAT CONTAIN YOUR DATA 
 
There is only 1 data file in this program that contain information that you have entered. 
The data file is: stordat.mdb 
This is the file that you should always keep backed up.  
Backing up the entire pupystuf folder is also a good idea if you have room on your 
backup media.  
 
2. BACK-UP SOFTWARE 
 
There are many backup utilities on the market. Windows 95/98 comes with a standard 
back-up utility that you may use. If it is already installed you can usually find it by 
clicking on Start, Programs, Accessories, System Tools, Backup. If it is not installed 
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you can install it from your Windows CD. Just click on Start, Settings, Control Panel 
and then double click on the Add / Remove Programs icon and then click the Windows 
Setup tab. You will find instructions on how to add and remove a variety of windows 
utilities.  
 
Windows ME does not have a built in backup utility. If you are running Windows ME 
you should use the steps below for copying your data file to a disk. 
 
Or you may use a different Back up utility that installs with the Various Back-up 
hardware devices available. 
 
3. HARDWARE DEVICES 
 
There are many devices that may be purchased to use for backing up your computer 
files. Visit your local computer store to see the devices available. I do recommend that 
you purchase a device that uses a type of media that will hold all of the files on your 
computer.  External hard drives are an excellent choice as they are cheaper, faster, 
more reliable, hold more and have multiple uses.  You may rather get a Zip Drive, Tape 
drive or other device. 
 
4. COPYING YOUR DATA FILES TO A DISK, Step by Step 
 
There are several ways to copy files to a disk. I will give you instructions for 
2 ways. 
 
The first way: 
 
STEP 1: Follow steps 1 through 5 of the Repair and Compact procedure on 
page 51. 
STEP 2: Follow step 6 of the Repair and Compact procedure EXCEPT: on 
the lower right side of the Window, in the box below the word “Drives:” you 
need to click the list button on the right edge of the box and select “A:” 
instead of “C:” and insert a blank disk. Then you click OK.  
 
This will put a Repaired and Compacted copy of your data file on the disk for 
you. If you use the same disk the next time you will receive the message 
shown in Step 7 asking if you want to replace the existing file. Select yes to 
put the newer copy of the file on the disk. 
 
The second way: 
STEP 1: Insert a 3 ½ in disk then open Windows Explorer (Click Start, 
Programs, Windows Explorer). 
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STEP 2: In the left pane of the window locate the folder pupystuf and click 
on it to highlight it. 
STEP 3: In the right pane of the window locate the file stordat.mdb and click 
on it to highlight it. 
STEP 4: Now click on it with your right mouse button so that a small menu 
pops up and choose Send To, 3 ½ in floppy.  
 
This sends a copy of the file to your disk. 
***If you receive a message that the disk is full or that the file won’t fit then 
you may need to Repair and compact the file before you copy it. 
***If you do not see the folder in the left pane you need to click the little box 
with the + next to your C: drive so that it changes to a – and the folders are 
visible below it. 
***If you do not see the stordat.mdb on the right side you need to click on 
the View menu and choose Folder Options and then click the View tab and 
put a dot in front of Show All Files and remove the check mark in front of 
Hide File Extensions…Click Apply and then Close. Now you will see all files 
and the extensions behind them. 
 
PART IX - REPAIR AND COMPACT 
  
We have provided a utility for repairing and compacting the database files that are 
used in the program. This utility can be opened by clicking the Doctor Bag icon labeled 
Comprep that is installed along with the PUPPY STUFF icon. 
 
1. REPAIRING AND COMPACTING A DATABASE 
 
If one day you go to use the PUPPY STUFF program and you get a message when you 
try to open the program, stating that it can’t open a file, and that it may be damaged… 
You will need to repair and compact your database. It is a good idea to Repair and 
Compact a database from time to time even if you do not encounter errors. This helps 
keep the database from taking up excess space on your hard drive due to blank and 
unused spaces that may develop in the records. 
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To Repair and Compact a database follow these simple steps: In this 
example we will be Repairing and Compacting the file “stordat.mdb” This is 
the file that contains your data.  You may also repair and Compact the 
“pupystuf.mdb” which contains the programming.  
You can only Repair and Compact one file at a time. You must 
complete all steps listed here for the file to be Repaired and 
compacted Properly. You will know you are done with a file because 
the utility will close automatically. 

STEP 1: Make sure the PUPPY STUFF program is CLOSED. 
STEP 2: Open the Repair and Compact utility by clicking on the Doctor Bag Icon 
Labeled Comprep that was installed along with the PUPPY STUFF program. 

STEP 3: You will see the following Window (screen) when the program opens. Notice 
the Window’s Title bar says “Repair Database”.  
Choose the stordat.mdb file in the list of files in the left pane of the window so that it is 
put in the box directly above the left pane of the window and just under the words File 
Name as shown below. Click OK. 

 
STEP 4: When the file has been successfully repaired you will see the following 
message box. Click OK. 
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STEP 5: Now the following Window will appear. Note that the Window’s Title bar now 
says “Database to compact from”.  
Again, Choose the stordat.mdb file in the list of files in the left pane of the window so 
that it is put in the box directly above the left pane of the window and just under the 
words File Name as shown below. Click OK. 

 
STEP 6: Now the following Window will appear. Note that the Window’s Title bar now 
says “Database to compact into” and the filenames are a lighter shade than before.   
Again, Choose the stordat.mdb file in the list of files in the left pane of the window so 
that it is put in the box directly above the left pane of the window and just under the 
words File Name as shown below. Do not use the suggested filename db1… Click OK. 
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STEP 7: The following message box will appear. You must Click Yes. This will replace 
the original file with the one that has been repaired and compacted.  
 
 

 
 
 
The Repair and Compact utility will automatically close when it is finished. If you would 
like to Repair and Compact another file you just open it again and follow the same 
steps for the next file. 
 
 

PART X - TECHNICAL SUPPORT 
WE OFFER FREE, UNLIMITED TECHNICAL SUPPORT OF THIS PROGRAM. 
 
EXCEPTION: We DO NOT support the Import, Export and Output To options available 
from the program. We also DO NOT support the Use of your data within other 
applications. This is because there is such a wide range of possibilities that we could 
not explain them all. We will answer simple questions pertaining to the way your data is 
formatted within our software only. 
 
FOR QUESTION OR COMMENTS CONCERNING THIS PROGRAM, OR IDEAS FOR 
THE NEXT VERSION, PLEASE FEEL FREE TO CONTACT US. 
PH.: (217) 696-2551, FAX: (217) 696-2802,  E-mail: askme@ezkennel.com 
OR WRITE TO : 
CHAPMAN PET PROGRAM 
1951 HWY 61 
LORAINE, IL  62349  
   
NOTE:  I do not guarantee any regular hours of availability by Phone, but this is a 
home office and I am usually in the office from 9:00 AM to 3:00 PM CST on Mon., 
Tues., Thurs. and sometimes on Fri. Normally If I am not available during business 
hours you will get the answering machine and be able to leave a message.  I will return 
your call ASAP! Other times you will hear a message about our hours but no incoming 
messages are recorded. We are never open on Sundays.  
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
 

Our Motto is: 
 

JESUS AND A PUPPY 
CAN LICK ANYTHING! 


