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PART I - INTRODUCTION 
 
1. INTRODUCTION 
 
Thank you for purchasing E-Z PEDIGREE BASIC. This program was designed for 
building a relational pedigree database. 
  
In this program you will never need to re-enter, copy and paste, extract or fill it up. The 
relational technology used allows the program to automatically fill any animal’s 
pedigree with all ancestors that you have entered into the database and print 3 and 4 
Generation pedigrees with picture, border and color options.  
 
In this documentation you will find instructions for use of the program. E-Z PEDIGREE 
BASIC is very easy to use. If you are familiar with other windows programs you will feel 
right at home. If you don’t know much about computers you will be amazed at how easy 
it really is. This User’s Manual should contain about anything you want to know about 
what you can do in the program. Much of the information provided here is also 
available in the Help forms in the program. But please feel free to contact us should 
you have any questions. 
 
 
2. COPYRIGHT NOTICE 
 
E-Z PEDIGREE BASIC and this document are copyrighted. 
This software is owned by Stacy L. Chapman, dba Chapman Pet Programs and is 
protected by United States Copyright laws and international treaty provisions. You may 
not reverse engineer, decompile, disassemble, or create derivative works from the 
software. 
 
3. LICENSE AGREEMENT 
 
The registered User only, is permitted to use this program on one computer, to maintain 
records for their own use. Ownership of this program is not transferable. When 
using an upgrade the ownership of all previous versions must also be retained. 
This program may be distributed to others for use as a demo only, as long as it is 
copied from the original disks, and distributed with all files contained on the original 
disks. The data file “peddata.mdb” may be shared with other users. 
The need to call and get a registration code is the method we have been forced to use 
to prevented dishonest people from sharing the software. We apologize for the 
inconvenience to the honest people. We need for everyone who uses the program to 
pay for it in order to keep providing updates and support for the software. 
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4. DISCLAIMER  
 
THIS SOFTWARE AND MANUAL ARE PROVIDED “AS-IS”. I disclaim all warranties 
relating to this software or manual, whether express or implied, including without 
limitation any implied warranties of merchantability or fitness for a particular 
purpose. I will not be liable for any incidental, consequential, indirect or similar 
damages due to loss of data or any other reason. The user assumes the entire 
risk as to the accuracy and use of this product. This agreement shall be governed 
by the laws of the State of Illinois, and any legal action brought in a State or 
Federal Court of competent jurisdiction located in Adams County, Illinois. The 
parties hereby consent to jurisdiction of said courts. 
 
I AM NOT RESPONSIBLE FOR LOST DATA. You should make regular back-ups of 
your data. See the “Back-ups” section of this book.   
 
5. LIMITED WARRANTY 
 
To the registered User only, Chapman Pet Programs provides the following warranty: 
For a period of ninety (90) days from the date of purchase, as is evidenced by a copy of 
your receipt, that: (1.)The Software, unless modified, will perform substantially the 
functions described in this owners manual provided by Chapman Pet Programs. 
(2.) The Software media provided will be free from defects in material and workmanship 
under normal use. 
  
6. ASSUMPTIONS 
 
This book assumes that you are familiar with the windows operating system that you 
are using. We will try to explain the use of features in the program as best we can, but 
it is your responsibility to know how to use windows. 
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PART II – INSTALLATION & SYSTEM REQUIREMENTS 
 
1. SYSTEM REQUIREMENTS 
 
This program requires an IBM compatible Pentium PC or higher computer with a 
minimum of 24MB of RAM, a hard drive with at least 15M of free space, Windows 3.1, 
95, 98, ME or above, a Mouse and a CDROM drive.  More hard drive space will be 
required if you are adding pictures and logos. 
 
2. INSTALLATION 
 
WIN 3.1 INSTALLATION 
 1. Start Microsoft Windows 
 2. Insert the CD, If installation does not start automatically continue with step 3. 
 3. Select Run from the File Menu 

4. Type X:\Setup in the Command line Box (Replace the X with your CDROM 
drive letter) 

 5. Choose the OK button 
 6. Follow the On Screen instructions 
 
 
WIN 95/98/ME/XP INSTALLATION 
 1. Start your computer 
 2. Insert the CD, If installation does not start automatically continue with step 3. 
 3. Click on the START button and select RUN 

4. Type X:\Setup in the Command line Box (Replace the X with your CDROM 
drive letter) 

 5. Choose the OK button 
 6. Follow the On Screen instructions 
 
 
 
3. PRODUCT REGISTRATION IS REQUIRED 
 
It will be necessary for you to register the software when first opened or after the trial 
period (which ends 10 days after the first use or after 10 uses of the program), 
whichever comes first, in order to continue use. To Register the software you must call, 
fax or e-mail us to receive your personal Registration Code. When requesting your 
registration code you will need to provide the purchaser’s full name and have the 
correct system number as displayed on the E-Z PEDIGREE BASIC registration form 
that appears when you open the program. Once the registration code has been 
entered, you will not be prompted again. Every Computer has a different system 
number even if the program is installed from the same cd. Be sure you give us the 
correct system number from your computer when you call to register. 
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PART III - PROGRAM BASICS 
 
1. DEFINITIONS 
Here are a few common definitions. For more information, buy a computer 
dictionary, also the Windows for Dummies Books are very good. 
 
It is important to know a few computer terms so that you can correctly identify 
things on your screen.  This is extremely helpful (and saves you money) if you are 
going to telephone someone for help with a problem and they are not able to see your 
computer! Phone time can be reduced drastically. It is also helpful if you relay exact 
problems by writing down messages that appear and exactly what happened or what 
you were doing when you had the problem.  
 
*Active Window - the window on your desktop that has the focus, usually the one on 
top of (covering) the other windows. 
*Click - Press the left mouse button and release 1 time 
*Clipboard - an invisible place in your computer that holds things for you until you 
need them or replace them with something else. 
*Current Record - The record that is visible on the form, or the record your cursor is in. 
*Cursor - The little ” I “ line that blinks to let you know where you are on the screen. 
*Desktop - The background area of your screen. 
*Dialog Box - A small form that pops up with available choices for various tasks. 
*Field - A box or place designed for a particular piece of information. 
*Field Selector - The gray bar at the top of a column in a datasheet. 
*Form - A screen or Window where you view or edit information. 
*Icon - A small square with a picture on it, usually found on your desktop. When you 
doubleclick an icon it usually opens a program. 
*Menu – A list of options. 
*Menubar - the row of words along the top of the window containing words like File, 
Edit, View... (when you click on one it opens a menu) 
*Navigation Bar - The small bar at the bottom right corner of a form window, containing 
4 buttons and Record x of x. 
*Re-Boot- Simply means to shut the computer off and turn it back on. 
*Reformat a Computer – This is when you erase all data, programs and settings from 
the hard drive and usually includes reinstalling them as it was when new.  
*Record Selector - The gray block on the left side of a record in a form. 
*Required Data – Means data must be entered in a specified field in order to continue 
or to save the record. 
*Right-Click – To click with the right mouse button, rather than the left button. 
*Selection – The highlighted text or records. Can also be the current record. 
*Subform - A form within a form. Such as a vaccination record on a litter record. 
*Title Bar - The colored bar across the top of a window that usually tells you what 
window you are looking at. 
*Unique – One of a kind or only used once. 
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2. MENUBAR COMMANDS 
 
Not all of the commands on the menubar are available for all of the FORMS.  
You will probably use the buttons on the Forms rather than the Menubar for the basic 
functions in the program. 
The Menubar that is displayed through most of the program looks like this. 
 
File     Edit     View     Format     Records 
 
The Menubar is located at the top left side of your screen. 
The Menubar for the Main Menu only has a simplified  File menu. 
Following is a brief explanation of each command available from the menubar. 

File 
 
Save Form - Saves changes you have made to the print setup or the layout and format 
of the datasheet view of the form you are working in. 
 
Save Record - Saves changes you have made to the current record. Note: Record 
changes are saved automatically when you move to a different record or close a form. 
 
Output To - Opens a dialog box for selecting options for copying records into various 
other file formats. See Part XI of the User’s manual for more detail on this option. 
 
Import - Opens a dialog box for selecting Import options. See Part XI of the User’s 
manual for more detail on this option. 
 
Export - Opens a dialog box for selecting Export options. See Part XI of the User’s 
manual for more detail on this option. 
 
Print Setup - Opens the Print Setup dialog box where you choose various printing 
options. See Part V, Printing, in the User’s Manual. 
 
Print Preview - Opens the print preview window to show you what the current form or 
report will look like when printed. See Part V, Printing, in the User’s Manual. 
 
Print -  Opens the Print Dialog box to select print options. See Part V, Printing, in the 
Users Manual. 
 
Exit - Exits the program. 
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Edit 
 
Undo - Use this command to undo the last thing you done. You may also press the 
ESC key 1 time to undo changes in a single field or 2 times to undo changes in an 
entire record. 
 
Undo Current Record - Use this command to undo changes made to the entire record. 
You may also press the ESC key 2 times. 
 
Cut - Remove the selected text or record and puts it on the invisible clipboard. 
 
Copy - Makes a copy of the selected text or record (highlighted) and puts it on the 
clipboard. 
 
Paste - Puts a copy of whatever is on the invisible clipboard into the field where you 
have your cursor. When pasting an entire record you must first choose Edit, Select 
record and then Edit, Paste. 
 
Delete - Deletes the current field, the selected text or the selected record. 
 
Delete Current Record – Deletes the record you are viewing. 
 
Select Record - Selects the current record so that you may print it, delete it or Paste 
another record into it. Records can also be selected by clicking on the gray bar to the 
left of the record if it is available. 
 
Select all Records - Selects all of the records in the current form so you may print, 
delete them or whatever. 
 
Find - Opens the Find Dialog box used to do a search. You may also open this Dialog 
box by pressing the “ F7” key on the keyboard. For more information, see P.21  
 
Replace - Opens the Replace Dialog box. You may also open this dialog box by 
pressing (Shift + “F7”) For more information, see P.22  
 
 

View 
 
Form - View the current form in Form View. 
Datasheet - View the current Form in Datasheet View. (Rows and Columns of data) 
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Format 
(The Format commands are only available in Datasheet View) 

 
Font -Opens a dialog box to change the Font properties. 
 
Row Height - Opens a dialog box to change the Row Height. 
 
Column Width - Opens a dialog box to change the column width.  
 
Hide Columns - Hides the selected columns. 
 
Show Columns - Opens a list of all available columns for you to select which ones you 
want to be visible. 
 
Freeze Columns - Freezes Selected columns so that when you scroll across the 
datasheet these columns will remain in view. 
 
Unfreeze All Columns - Does just that. 
 
Gridlines - Toggles the gridlines of the datasheet Off/On. 
 

Records 
 

GoTo - Offers you a choice of going to the First, Last, Next, Previous, or a New 
record in the current Form. 
 
Refresh - Refreshes the form to show any changes or to do recalculations of any 
calculated field. 
 
Quick Sort - Allows you to sort the records in the current form in Ascending or 
Descending order according to the field that your cursor is in when you choose this 
command. 
 
Show All Records - Use this command to view all of the records if a filter has been 
applied and some records are not included. 
 

Help 
 
Help Topics – Displays a list of Help topics  to choose from. 
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3. NAVIGATION 
(See optional techniques in the “HOT KEYS” section) 
 
FROM FIELD TO FIELD IN A RECORD 
 
The cursor blinks in the field that you are in. Press enter or Tab to move to the next 
field, or use your mouse to select the field you wish to move to by clicking on it 
 
FROM RECORD TO RECORD IN A FORM 
 
To move from one record to another, you may use several methods. 
*At the bottom of the form there is a bar with buttons on the bottom left side of the form 
window that looks like the diagram below. This is called the navigation bar. When 
available you may use this method of moving from record to record.  
 
This Button moves you to the first record in the form. 
 This Button moves you to the previous record. 
       This is the number of the current record. 
         This is the total number of records available. 
     This Button moves you to the next record. 
            This button moves you to the last record. 
 
<I < Record 1 of 3 > I> 

  
             By changing the record number here, you will automatically move 
to the record corresponding to the number that you enter. 
 
*You may use the GoTo command on the Records Menu. 
*You may use the Find command on the Edit Menu. 
*We have added buttons at the top of the Entry form to move to the next or previous 
record. 
*Using the Page down or Page up keys on the keyboard will move you to the bottom or 
top of a form or to the next or previous record. 

• You may do a search for a specific record, See Search, Find and Replace 
section of this user’s manual. 
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4. ENTERING AND EDITING DATA 
 
Not all forms allow entering or editing, the pedigrees are for viewing or printing only, 
in these forms you will not be able to edit or enter any information. These types of 
forms get data from entries made in the “Entry Form” in the program.  
 
Use the “Entry Form” to enter records. This is the main screen (blue) of the program 
that has all the nice buttons to make changes and open the related pedigrees. In the 
Entry form you may also enter or edit data in the Datasheet View. This is sometimes 
handy for faster entry of a large number of records at one time. 
 
See other sections of this book for details about selecting records, adding, deleting, 
and so on if you need more specific help. Tip: the datasheet view and all the formatting 
options available for it is really cool. 
 
Only enter each animal one time. Each animal that you put into the program is linked 
to related animals by the 3 registration numbers entered in it’s record. The program will 
not allow a registration number to be used 2 times in the animals Registration Number 
field but the Dam and Sire registration numbers may be the same for many animals.  
UNLESS…The only time you may want to enter an animal into the program more than 
one time is if you want to create pedigrees for more than one type of registration for the 
same animals. For example if entering Dogs, they may be registered with AKC and 
APRI and you may want the ability to print a pedigree for either registry. In this case 
you may want to enter each dog that is dual registered into the database 2 times. 
It is also possible to have a pedigree that has more than one type of registration 
used within it. For example if you have a dog with an APRI registration but the Dam 
and Sire of the dog are only AKC registered you would simply enter the Dam and Sire’s 
AKC numbers and the pedigree would still pick up the rest of the pedigree (if ancestors 
have been entered) even though not all animals are registered through the same 
registry.  
 
UNDERSTANDING RELATIONSHIPS This program is a “RELATIONAL DATABASE”. 
The relationships that are built into the program are what makes it possible to eliminate 
the need to enter information more than once. The program forms relationships by 
exact matches in fields.  
FOR EXAMPLE: You enter Spot into the program and you put his Sires registration 
number as AAA111 and then you enter the sire and on his record you put his 
registration number as AAA 111. The program will not fill in spots sire because the 
space between the AAA and the 111 makes the registration number different. 
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To enter a new record you must first go to a new blank record in one of the following 
ways. 
 
1.)Choose GoTo/New from the records menu. 
2.) Click the “NEW” button on the form (blank page button). 
3.) Scroll to the last record and click the next record button on the navigation bar. 
4.) Move to the record with an( *) in the record selector bar at the bottom of the 
datasheet view. 
  
Once in a new record, simply enter the desired info. All fields need to be completed 
except for the line 2 field and the picture which is optional. 
 
A new record is automatically saved when you move to a different record or close the 
form. You will receive a message if there is a reason the record can’t be saved. For 
example if you have entered a Registration # that has already been used.  
 
The Breed field is a list field that contains a list of all breeds that have been 
entered. This list is updated automatically each time the form is opened. Tip: If 
you are entering a new breed and intend to enter several records of that breed it would 
be best to enter the first one and then close the program and re-open it so that the list 
is updated to display the new breed. 
 
To edit a record, simply go to the record you would like to modify and make any  
desired changes.  
The changes you have made will automatically be saved when you move to another 
record or close the form. If you change your mind before the record is saved you may 
press ESC to back out of the changes in a single field or press ESC 2 times to undo all 
changes made to the record. 
You may also select “Save Record” from the “File” Menu to update related pedigrees 
that may be opened by pressing a button on the entry form. 
  
The Breed field contains a dropdown list, you can begin typing until the desired breed 
appears if it has been previously entered, this is called quickfill or click the arrow key at 
the right end of the field (or press “F4”) to display a list of all breeds that have been 
previously entered. Click the one you want from the list or hit enter when the quickfill 
matches the entry you want. If the breed you want to enter is not in the list simply type it 
in. The next time you open the form the list will be updated to include that breed. 
 
 
To sort records in a form, select the field you want to sort. (just click in the field) In a 
datasheet click in, or in a datasheet select the column or columns you want to sort (see 
the customizing datasheets section of this book for more detail) and then Choose Quick 
Sort from the Records menu, and then choose Ascending or Descending. 
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To Select a record choose Edit, Select Record from the Menubar or in datasheets you 
can click the gray bar to the left of the record to select it. 
 
To delete a record in a form or datasheet select the record or records you want to 
delete then from the Edit menu, choose Delete (or press the DEL key). If you don’t 
select the record first you will just be deleting data from the visible fileds and a blank 
record will still be there and you could get a message that certain fields are required. 
Press ESC 2 times to put the record back as it was and then select the record as 
described above and then Delete it. If you are entering a new record that has not been 
saved yet and change your mind just Press Esc 2 times to back out of it rather than 
delete it. 
 
Here is a simple list of editing techniques. 
 
 

Replace an old value with a new value  With the field selected 
 type a new value 
  
Insert a value in a field Type the new value at the blinking 

insertion point 
  
Select the current field or remove the  Press F2  
selection from the current field 
 

 

Move the insertion point within a field 
 

Press ARROW keys 

Undo changes to the current field or record 
 

Press ESC 

Insert a new line character in a field 
 

Press CTRL+ENTER 

Replace the value in a field with the value of 
the same field in the previous record 

Press CTRL+" 

  
Replace the value of a field with its default 
value 

Press CTRL+ALT+SPACEBAR 

  
Open a combo box list to display choices 
 

Press ALT+DOWN ARROW 

View and edit the current field in the Zoom box  Press SHIFT + F2 
  
Save changes to the current record Move to next record 
 
 

press SHIFT+ ENTER or close the 
form or datasheet 
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Refresh displayed records 
 

Press F9 

Requery underlying records to reflect Press SHIFT + F9 
changes  
5. FILTERING AND SORTING DATA 
 
What is a Filter? 
 
A filter is a method of removing records from a form so that you may view, edit or print 
only a certain set of related records.  Choosing the Filter button on the “Entry form” 
allows you to select a breed so the records in the form will change to include only the 
records for the breed you selected. 
 
Removing the Filter: After the filter is applied not all of the records are being displayed 
in the form, you may choose the remove filter button on the form or  “Show All Records” 
from the “Records” Menu to cause the form to include all of the records again.  
 
SORTING RECORDS 
 
What is Sorting? 
 
When you sort records you do not change or remove any of the records displayed, you 
simply put them in a different order. 
 
Each time the program is opened the records are automatically ordered according to 
the registration number but you may re-order the records by any field on the form. 
 
For example: if you would like to see your Records in order by Name you would do 
this:  
1.) Put your cursor anywhere in the Name field in any record.  
2.) With your mouse, click on the “Records” menu and choose “Quick Sort” and then 
“Ascending”. 
 
This will cause your records to be re-ordered as desired. 
 
For more information read the rest of this section. You can sort records in Form or 
Datasheet View into a different order than they are usually displayed by using the 
Quick Sort command. 
 
In a form, you can sort the contents of only one field at a time; in a datasheet, you can 
sort the contents of one, two or three adjacent datasheet columns in a single operation. 
If you select more than one column, E-Z PEDIGREE BASIC sorts records starting with 
the leftmost column. 
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You can sort records for display in either ascending or descending order, and you can 
sort by any field on the form except the Picture field. 
Ascending means records are sorted from A to Z and I to 10 while descending means 
from Z to A and 10 to 1. 
 
Sorting Two or Three Columns in a Datasheet 
Suppose you want to see the records sorted by Breed. Within each Breed you want to 
sort records by Sex, arrange columns in the datasheet so that the Breed column is 
directly to the left of the Sex column. (For information on moving datasheet columns, 
See Part IV, Datasheet View) 
Select the Breed and Sex columns (highlight them), and then click the Sort Ascending 
button on the toolbar.  E-Z PEDIGREE BASIC sorts records first by Breed then by Sex. 
Records are sorted by values in the Breed and within each Breed the Sex are sorted. 
 
 
6. SEARCH, FIND AND REPLACE 
 
To search for a particular record you have several options. 
* You may use the navigation bar buttons to simply scroll through the records. 
* You may use the search button on the form to search in all fields for the specified text. 
* Or you may want to search for a particular record according to a single field. 
 
Finding Data 
When you want to find a specific record or find certain values within fields, you can use 
the Find command to go directly to a specific record. You can also use the Find 
command to navigate through records and find one record after another. The Find 
dialog box always stays on top of your form or datasheet until you choose the Close 
button. 
 
To make searches faster, E-Z PEDIGREE BASIC searches only the current field unless 
you select the All Fields option in the Find dialog box 
 
To find a specific value in a field 
1.Move to the field where you want to search. 
2.Choose Find from the Edit menu (or click the “F7” key on the keyboard). 
3.In the Find What box, type the value you want to find.  
4.Choose the Find First button (or press the ENTER key). 



 18 
 

E-Z PEDIGREE BASIC moves to the record (if it exists). You may have to move the 
Find dialog box out of the way to see the record. 
5.Choose the Find Next button to find the next occurrence of the specified value if one 
exists. 
-Or-Choose the Close button to close the dialog box. 
 
Tip: After you close the Find dialog box, you can always find the next occurrence of the 
value you most recently searched for by pressing SHIFT+F4. 
 
 
Find Options 
When you use the Find command, you can choose several options to tell E-Z 
PEDIGREE BASIC how to find the data you want. 
 
Searching in All Fields 
E-Z PEDIGREE BASIC usually searches only the current field, because it's fastest to 
search in just one field. However, if you want to find values in any field in a form or 
datasheet, select the All Fields option in the Search In option group. 
 
Finding Text Within Fields 
E-Z PEDIGREE BASIC usually searches whole fields, not the partial contents of fields 
(Match Whole Field is the fastest type of search). If you want E-Z PEDIGREE BASIC to 
look within each field for certain text, select Any Part Of Field from the Where box. For 
example, you might want to find any field containing a certain word. E-Z PEDIGREE 
BASIC finds each occurrence of the text you specify, even if the text occurs more than 
once in the same field. 
If you know that the text you are looking for is at the beginning of a field, select Start of 
Field from the Where box to make the search faster. For example,, you may want to 
search for a certain first name at the start of a field that contains a lengthy registered 
name . 
 
Matching Case 
Usually, E-Z PEDIGREE BASIC searches text regardless of whether it's uppercase or 
lowercase. For example, E-Z PEDIGREE BASIC finds "Tom" whether you specify "tom" 
or "TOM." If you want to find only the exact text you type, select the Match Case option 
 
Finding and Replacing Data 
Sometimes you must make the same change to your data in several places. If you want 
E-Z PEDIGREE BASIC to find occurrences of specific text and replace them with 
different text, you can use the Replace command. With the Replace command, you can 
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look at each occurrence of the specified text before you make the change, or you can 
make global changes. To make searches faster, E-Z PEDIGREE BASIC searches only 
the current field unless you select the All Fields option in the Replace dialog box (see 
"Find Options" earlier in this chapter). 
 
To find and replace all occurrences of specified text 
1. Move to the field where you want to search and replace. 
2. From the Edit menu, choose Replace. 
3. In the Find What box, type the text you want to find. 
4. In the Replace With box, type the replacement text. 
5. Choose the Replace All button. 
E-Z PEDIGREE BASIC prompts you to confirm the changes you made with the Replace 
command. 
6. Choose the Close button to close the dialog box. 
 
To find and replace occurrences of specified text one at a time 
I.Move to the field where you want to search and replace. 
2.From the Edit menu, choose Replace. 
3.In the Find What box, type the text you want to find. 
4.In the Replace With box, type the replacement text. 
5.Choose the Find Next button. 
E-Z PEDIGREE BASIC moves you to the next occurrence of the text you specified and 
selects it. You may have to move the Replace dialog box out of the way to see the 
record. 
6.To replace the specified text and move to the next occurrence, choose the Replace 
button. E-Z PEDIGREE BASIC doesn't prompt you to verify that you want to change the 
contents of a single field. 
-Or-To leave the selected text as is and find the next occurrence instead, choose the 
Find Next button again. 
7.When you finish replacing, choose the Close button to close the dialog box. 
For example: If you have 50 Shetland Sheepdogs entered in the program as Sheltie 
and you realize that they should have been entered as Shetland Sheepdog you can 
change all of the records at once using the replace feature. 
1.) Click on the Breed field in the first Record you see. 
2.) Select “Replace” from the “Edit” menu. or use the Hot Key Combination (Shift + F7) 
to open the “Replace” dialog box. Enter the word “Sheltie” as the text to Find and enter 
the words “Shetland Sheepdog” as the text to Replace it with. 
3.) Select the “Replace all” button to replace all of the Shelties with Shetland 
Sheepdog. 
 
Using Wildcard Characters 
When you use the Find and Replace commands, you may not always know exactly 
what you are searching for. For flexibility, you can use the question mark (?), the 
asterisk (*), and the number sign (#) as wildcard characters in the Find What box in 
either the Find or Replace dialog box. 
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A question mark stands for any single character in the same position as the question 
mark. An asterisk stands for any number of characters in the same position as the 
asterisk. A number sign stands for a single numeric digit in the same position as that 
numeric digit (useful when you want to find a number, but not a letter). 
 
You can use characters in square brackets to find one of several characters. For 
example, to find the letter Q or X' type [QX]in the Find What box. You can indicate 
ranges of characters with a hyphen. For example, to find any letter between A and Z, 
type [A-Z]. You can specify characters you don't want to find by including an 
exclamation point (!) after the first bracket. For example, to find all characters except 
the letter M, type [!M]. 
 
The following examples illustrate the use of wildcard characters. 

 If you search for                  E-Z PEDIGREE BASIC finds 
 Sm?th                    Smith 
                     Smyth 
 
 L*ng                    Ling 
                     Leveling 
                     Leka Travel and Trading 
 #th                    5th 
                     8th 
 
 *th                    128th 
                     Perth 
 
 Paul[ao]                    Paula 
                     Paulo 
 
 Paul[!ao]                    Pauli (but not Paula or Paulo) 
Note If you want to find one of the wildcard characters itself, enclose it in square 
brackets. For example, to find the value "#1", type [#]1. 
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7. HOT KEYS & ACCELERATOR KEYS 
 

HOT KEYS 
TAB, RIGHT ARROW 

or ENTER 
moves to the next field. Note:Sometimes the Enter key will move to 
the next line of the same field. 

SHIFT & TAB or 
 LEFT ARROW 

moves to the previous field. 

HOME moves to the first field in the current record. 
END moves to the last field in the current record. 

PAGE DOWN moves to the next record. 
PAGE UP moves to the previous record. 

Ctrl & + moves to a new record. 
Ctrl & - deletes the current record. 

Shift & Enter save changes to current record. 
F4 or  

Alt & DOWN ARROW 
drops down the list for the current field, if available. 

 NOTE: use the up and down arrows to move within a drop 
down list and the tab to close the list and go to the next field. 

Ctrl & ; inserts the current date. 
Ctrl & ‘  

or Ctrl & “ 
copies the value from the same field in the previous record. 

F7 or 
Ctrl & F 

opens the Find Dialog Box 

Shift & F7 
or Ctrl & H 

opens the Replace Dialog Box 
 

Shift & F4 Find the next occurrence of the text specified in the Find or 
Replace Dialog Box AFTER THE DIALOG BOX IS CLOSED. 

 
ACCELERATOR KEYS 
Accelerator keys are used in place of the mouse click. The keys available will vary. You 
will know what keys you can use by looking for letters that are underlined on the 
menubar and the commands available from the menu bar. To use an accelerator key 
you simply hold down the “Alt” Key while pressing the Underlined letter of the 
command. 
For example to choose “Print” from the “File” Menu you would press (Alt + F) to display 
the File Menu and then (Alt+P) to display the Print Dialog box. 
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PART IV - DATASHEET VIEWS 
 
1. CHANGING TO DATASHEET VIEW 
 
To change to Datasheet view, you select View, Datasheet from the menubar. Only the 
“Entry Form” has this view available. 
 
2. CUSTOMIZING DATASHEETS 
 
E-Z PEDIGREE BASIC provides several ways for you to change the display of the 
datasheet. You can change the width of individual columns to fit the field values they 
display. You can re-order, hide, or freeze columns. And you can change the row height 
and font. 
When you save or close a form, E-Z PEDIGREE BASIC asks if you would like to save 
changes to the form.  This includes appearance of the datasheet as well as any 
changes to the Print Setup. If you choose yes, the next time you open the datasheet, it 
appears just the way you left it. Also any print settings will be as you saved them. 
 
Changing Column Width and Order 
If the columns in a datasheet don't fit the field values they display, you can change the 
width of each column. Or if you want to view fields in a different order, you can easily 
rearrange datasheet columns. 
 
To change the width of a column 
I.) Position the mouse pointer at the right side of the field selector for the column you 
want to resize. 
2.) Drag the column border to the desired size, 
     
To resize a column to fit the data it displays 
*Double-click the right edge of the field selector for the column you want to resize. 
-Or- 
*From the Format menu, choose Column Width, and then choose Best Fit. 
E-Z PEDIGREE BASIC sizes the column to fit the column heading and the longest 
value currently displayed in the column (not necessarily the longest value stored in the 
field). 
 
Tip: To resize multiple columns at once, select the columns you want to resize (or the 
entire datasheet), then drag or double-click the right edge of any one of the field 
selectors. E-Z PEDIGREE BASIC sizes all the selected columns to fit the data 
displayed. 
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To move a column 
I. Select the column you want to move by clicking the field selector. To select more than 
one column at a time, hold down the SHIFT key and click the other column(s) you want 
to select 
 
2. Click the field selector again and drag the column to its new position. As you drag 
the column, its destination is indicated by a solid bar between columns. 
   
Hiding and Showing Columns 
Since you often have more fields in form or datasheet than can fit on a page, you might 
want to hide certain columns. For example, you might want to hide a customer address 
field that's too wide so you can view  or print just the Customer Name and Phone 
Number fields. 
 
To hide a column in a datasheet 
I. Select the column you want to hide by clicking its field selector. 
2. From the Format menu, choose Hide Columns. 
 
To show hidden columns in a datasheet 
1. From the Format menu, choose Show Columns. 
2. Select the column(s) you want to show, and then choose the Show button. 
3. Choose the Close button. 
 
Freezing and Unfreezing Columns 
If you want one or more fields to be visible at all times, you can freeze the datasheet 
columns on the left side of the datasheet. When you scroll through a datasheet 
horizontally to view columns to the right, frozen columns remain visible on the left. For 
example, you might want a Dog’s ID and name to remain visible even when you scroll 
through the datasheet to see other fields. 
  
To freeze a column in a datasheet 
1. Select the column you want to freeze by clicking its field selector. 
To select more than one column at a time, hold down the SHIFT key and click the other 
column(s) you want to select. 
2. From the Format menu, choose Freeze Columns. 
 
To unfreeze all columns 
From the Format menu, choose Unfreeze All Columns. 
 
Changing the Font or Row Height of a Datasheet 
You can choose any font or font size in a datasheet. If the field values don't fit in the 
columns of a datasheet, you can change the row height to display more than one line of 
text in each row. Changes to font or row height affect the whole datasheet, not 
individual rows. 
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To change the font of a datasheet 
1. From the Format menu, choose Font, 
2. Select the font, style, and size you want, and then choose OK. 
 
To change the row height of a datasheet 
1. Position the pointer between two record selectors at the left side of the datasheet. 
2. Drag the row to the desired size. 
All rows in the datasheet change to the new row height. 
 
3. EDITING DATASHEET RECORDS 
 
Copying, Moving, or Deleting Data 
You may occasionally want to copy or move data in your E-Z PEDIGREE BASIC 
database. If you use other applications for Windows, such as Microsoft Excel or 
Microsoft Word for Windows, you may want to copy data to those applications. 
 
When you copy data, you can use the Copy command, which leaves the original data 
intact, or the Cut command, which deletes the data so you can move it elsewhere. 
Either command places the data onto the Clipboard. You can paste data from the 
Clipboard to another location. 
 
You can copy and paste data when you want to: 
 
•Copy a value from a field and paste it into another field or fields. 

 
•Copy data or records from E-Z PEDIGREE BASIC to another application for Windows, 
such as a spreadsheet or a word processor. 
 
Selecting Data 
Before you can copy, move, or delete data, you must select it. You can select: 
 
•Data within a field. 
•Data in two or more adjacent fields in a datasheet. 
•Data in one or more columns in a datasheet. 
•One or more whole records. 
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The following table lists keyboard techniques for selecting data or 
records. 
  
Select data in a field Move the insertion point to the start 

of Line 
 that you want to select. then hold 

down the 
 SHIFT key and move to the end of 

the 
 selection with the ARROW keys. 

 
Select or cancel the selection 
for the entire 
contents of the current field 
 

Press P2. 

Select adjacent fields in a 
datasheet 

With a field selected, hold down the 
SHIFT 

 key and press the appropriate 
ARROW key. 
 

Select the current column in a 
datasheet 
 

Press CTRL+SPACEBAR. 
 

Select the current record Press SHIFT+SPACEBAR. 
 

Select multiple records Press SHIFT+SPACEBAR, 
then SHIFT+ UP ARROW or SHIFT 
+ DOWN ARROW 
 

 
The following table lists mouse techniques for selecting data or 
records. 
  
Select data in a field Click where you want to start 

selecting and drag across the data. 
 

Extend a selection Hold down the SHIFT key and click 
the position you want to extend to. 
 

Select the entire contents of a 
field 

In a datasheet, click the left edge of 
the field in a form, click the fields 
label. 
 

Select adjacent fields in a Click the left edge of a field and 
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datasheet drag to extend the selection. 
 

Select a column in a datasheet Click the field selector at the top of 
the column you want to select. 
 

Select adjacent columns in a 
datasheet 

Click the field selector for the first 
column you want to select and drag 
to the last one. 
 

Select a record Click the record selector to the left 
of the record you want to select. 
 

Select multiple records Click the selector (gray bar on left) 
of the first record you want to select 
and drag to the last. 
 

Select all records  (datasheet 
only) 

Click the selector in the upper-left 
corner of the datasheet. 
 

 
Deleting Data 
After you select data in a field, you can delete it. You can also permanently delete 
entire records from your database. 
 
To delete data from one field 
I. Select the data you want to delete. 
2. From the Edit menu, choose Delete (or press the DEL key). 
 
To delete one or more records in datasheet view 
I. Select the record or records you want to delete. 
2. From the Edit menu, choose Delete (or press the DEL key). 
 
Copying or Moving Data in a Field 
Copying or moving data in a field is as easy as select, copy, and paste. After you copy 
data, you can either paste it over (replace) the contents of the destination field, or 
insert it into the existing contents. If you want to replace existing data with the contents 
of the Clipboard, select the data to be replaced before you paste. 
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To copy or move data from one field to another 

I. Select the data you want to copy or cut. 

2. Choose Copy from the Edit menu to copy data Or Choose Cut from the Edit menu to 
remove the data. 

 3. Move to the destination field. If you want to replace the current value of the 
destination field, select the whole field, If you want to insert text into the existing data, 
position the insertion point where you want the text to be pasted. 

4. From the Edit menu, choose Paste. 

Copying Multiple Fields 
With a datasheet you can copy data in more than one field or all the data in one or 
more entire columns. For example, you can select only names and registraion numbers  
then copy the data to another Windows-based application. 
 
If the source data has more fields than the destination datasheet, E-Z PEDIGREE 
BASIC doesn't paste the extra fields, If the destination datasheet has extra fields, E-Z 
PEDIGREE BASIC doesn't paste anything into them. 
 
To copy data from adjacent fields or from datasheet columns 
I. Select the fields or columns you want to copy or cut. 
2. Choose Copy from the Edit menu to copy Or Choose Cut from the Edit menu to move 
data 
3. Select the destination field or fields, or switch to the Windows application you want 
to paste the data into and then select the destination field or fields. 
4.  From the Edit menu, choose Paste.  
 
To copy an entire record 
1.) Open the form and record that contains the data you would like to copy. 
2.) Click on Edit, Select Record from the menubar to select the entire record. Note:It 
may not become highlighted but it is still selected. 
3.) Click on Edit, Copy from the menubar. This copies the entire record to the invisible 
clipboard. 
 
To paste a record  
1.) Open the empty record that you would like to paste the data into. 
2.) Click on Edit, Select Record. 
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3.) Click on Edit, Paste.  
 
Note It is not recommended that you try to paste outside data into E-Z PEDIGREE 
BASIC. If you copy data from outside E-Z PEDIGREE BASIC or from a table with field 
names or data types that don't match the destination, you may run into serious 
problems pasting them in. 
 
Correcting Mistakes with the Undo Command 
E-Z PEDIGREE BASIC always remembers the last change you make to your data. If 
you type data incorrectly, you can tell E-Z PEDIGREE BASIC to undo the changes as 
long as the record has not been saved. 
 
 
PART V – PRINTING 
 
The pedigree forms each have a button on the top left corner of the form that you may 
choose to print the pedigree displayed on screen. 
 
Printing Lists, While on the Entry Form select Datasheet from the View menu to open 
a List of all entries in the database. You can view, edit and print records from the Entry 
form in datasheet view.  To print records in the Datasheet view you choose Print from 
the File menu and choose the desired print options. Note: If the filter is applied before 
you switch to the datasheet view the records will remain filtered in the datasheet also. 
(For more information about working with datasheet views see the datasheet view help 
topic.) 
 
1. PRINT PREVIEW 

 
You can use Print Preview to see what your printed page(s) will look like when you 
print. You can also get a close-up view of previewed data, seeing selected portions of 
text at a greater magnification. Using navigation buttons, you can preview page-by-
page or move to exactly the page you want. 

 
To preview a Form  
Open the Form or pedigree you want to preview and then choose Print Preview from 
the File Menu. The first page to be printed is displayed in the Print Preview window. 
Although the print preview does not show the total number of pages to be printed you 
can use the buttons on the navigation bar at the bottom of the preview pane to move to 
additional pages. 
To see a close-up of preview click on the section you would like to enlarge. 
You can read the text by getting a closeup (zoomed) view of it. Once you've zoomed in, 
use the scroll bars to move to the top, bottom, or sides of the page. 
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To move between pages 
Using the navigation buttons in Print Preview, you can view pages sequentially or jump 
to any page in the document. 
 
2. PRINT SETUP 
 
I.) Open the form or pedigree 
2.) From the File menu, choose Print Setup. 
The Print Setup dialog box is displayed. 
3.) Set the appropriate printing options such as margins and spacing. You may need to 
click on the More button to see additional options.  
4.) Choose OK. 
 
To print selected records use the print button on the form or… 
1.) Select the records you want to print. In a form the record you are on is always 
considered the current record or you may select several records to print. 
2.) From the File menu, choose Print, the Print dialog box is displayed. 
3.) In the Print Range group, choose Selection. 
2.) Choose OK. 
 
3. SELECTING A PRINTER 
 
The printer you have selected as the default in your computer will automatically be 
used unless you choose another printer. To select a printer, you choose Print Setup 
from the File menu, and select the desired printer there.  
 
PART VI - PICTURES AND LOGOS 
 
There is one simple way to put pictures into the records so I am only going to explain 
that way. 
 
The simple way to add a picture to a record is: 

1.) Get the picture into your computer by whatever means you have available. Such 
as a scanner, digital camera, or pictures developed on disk. 

2.)  Open the program that you normally use to view and edit the pictures when you 
put them into the computer. Open the picture you want to use. Select the entire 
picture or part of it and copy it to your invisible clip board. Close or minimize the 
picture program. 

3.) Open E-Z PEDIGREE BASIC. Open the Entry form and go to the appropriate 
record. Click inside of the area where the picture is to be displayed. From the 
Edit menu choose Paste. 

WHA  LA… You have a picture in the record. 
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PART  VII - BACK-UPS 
 
1. BASICS 
 
There are 2 ways to save your data, You can Back-up or Copy your data files. 
 
To Back-up: Means to use a Back-up utility to store a copy of one or more selected 
files in an alternate location as a single file with a backup name. 
 
To Copy: Means to make an exact copy of a file or files in an alternate location. This 
can be another location on your computer such as a different folder or another drive, it 
can be copied to a disk, CD-RW or other media.  
 
Sometimes it is easier to just copy a file to a disk than to make a Back-up. See the step 
by step instructions in this section for copying your data files to a disk. 
 
Here are some general tips about making back-ups or copies of your data: 

o Make backup copies on a regular basis. Consider using automatic backup 
software. 

o Keep backup copies of your data off-site in case of a fire, flood, or other natural 
disaster. 

o Protect your backup copies by encrypting the files or locking up the tapes or 
disks. 

o Restore and read your backup copies periodically to ensure that your backup 
mechanism is working properly. 

o Maintain more than one backup copy in case both the original data and the 
backup are destroyed. 

 
How often you should back up or copy your data files depends primarily on how often 
the files are updated. For example, if you're the only person who uses your database 
and you add only a few records each day, it may be sufficient to back it up once a 
week. 
Just ask yourself if it is easier to backup or re-enter anything you stand to loose. 
 
2. FILES THAT CONTAIN YOUR DATA 
 
There is only 1 data file in this program that contains information that you have entered. 
The data file is: peddata.mdb 
This is the file that you should always keep backed up.  
Backing up the entire ezped folder is a good idea if you have room on your backup 
media.  
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3. BACK-UP SOFTWARE 
 
There are many backup utilities on the market. Windows 3.1,95/98 comes with a 
standard back-up utility that you may use. If it is already installed you can usually find it 
by clicking on Start, Programs, Accessories, System Tools, Backup. If it is not installed 
you can install it from your Windows CD. Just click on Start, Settings, Control Panel 
and then double click on the Add / Remove Programs icon and then click the Windows 
Setup tab. You will find instructions on how to add and remove a variety of windows 
utilities. Note: Microsoft removed the backup utility from Windows ME???  
 
Or you may use a different Back up utility that installs with the Various Back-up 
hardware devices available. 
 
4. HARDWARE DEVICES 
 
There are many devices that may be purchased to use for backing up your computer 
files. Visit your local computer store to see the devices available. I do recommend that 
you purchase a device that uses a type of media that will hold all of the files on your 
computer.  External hard drives are an excellent choice as they are cheaper, faster, 
more reliable, hold more and have multiple uses.  You may rather get a Zip Drive, Tape 
drive or other device. 
 
5. COPYING YOUR DATA FILES TO A DISK, Step by Step 
 
There are several ways to copy files to a disk. I will give you instructions for 2 ways. 
 
The first way: 
STEP 1: Follow steps 1 through 5 of the Repair and Compact procedure on page 51. 
STEP 2: Follow step 6 of the Repair and Compact procedure EXCEPT: on the lower 
right side of the Window, in the box below the word “Drives:” you need to click the list 
button on the right edge of the box and select “A:” instead of “C:” and insert a blank 
disk. Then you click OK.  
 
This will put a Repaired and Compacted copy of your data file on the disk for you. If you 
use the same disk the next time you will receive the message shown in Step 7 asking if 
you want to replace the existing file. Select yes to put the newer copy of the file on the 
disk. 
 
The second way: 
STEP 1: Insert a 3 ½ in disk then open Windows Explorer (Click Start, Programs, 
Windows Explorer). 
STEP 2: In the left pane of the window locate the folder ezped and click on it to 
highlight it. 
STEP 3: In the right pane of the window locate the file peddata.mdb and click on it to 
highlight it. 
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STEP 4: Now click on it with your right mouse button so that a small menu pops up and 
choose Send To, 3 ½ in floppy.  
 
This sends a copy of the file to your disk. 
***If you receive a message that the disk is full or that the file won’t fit then you may 
need to Repair and compact the file before you copy it. 
***If you do not see the folder in the left pane you need to click the little box with the + 
next to your C: drive so that it changes to a – and the folders are visible below it. 
***If you do not see the peddata.mdb on the right side you need to click on the View 
menu and choose Folder Options and then click the View tab and put a dot in front of 
Show All Files and remove the check mark in front of Hide File Extensions…Click Apply 
and then Close. Now you will see all files and the extensions behind them. 
 
PART VIII - REPAIR AND COMPACT  
 
We have provided a utility for repairing and compacting the database files that are 
used in the program. This utility can be opened by clicking the Doctor Bag icon labeled 
Comprep that is installed along with the E-Z PEDIGREE BASIC icon. 
 
1. REPAIRING AND COMPACTING A DATABASE 
If one day you go to use the E-Z KENNEL program and you get a message when you 
try to open the program, stating that it can’t open a file, and that it may be damaged… 
You will need to repair and compact your database. It is a good idea to Repair and 
Compact a database from time to time even if you do not encounter errors. This helps 
keep the database from taking up excess space on your hard drive due to blank and 
unused spaces that may develop in the records. 
 
To Repair and Compact a database follow these simple steps: In this example we 
will be Repairing and Compacting the file “peddata.mdb” This is the file that contains 
most of your data.  You can only Repair and Compact one file at a time. You must 
complete all steps listed here for the file to be Repaired and compacted Properly. 
You will know you are done with a file because the utility will close automatically. 
 
STEP 1: Make sure the E-Z PEDIGREE BASIC program is CLOSED. 

STEP 2: Open the Repair and Compact utility by clicking on the Doctor Bag Icon 
Labeled Comprep that was installed along with the E-Z KENNEL program. 
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STEP 3: You will see the following Window (screen) when the program opens. Notice 
the Window’s Title bar says “Repair Database”.  
Choose the peddata.mdb file in the list of files in the left pane of the window so that it 
is put in the box directly above the left pane of the window and just under the words 
File Name as shown below. Click OK. 

STEP 4: When the file has been successfully repaired you will see the following 
message box. Click OK. 

STEP 5: Now the following Window will appear. Note that the Window’s Title bar now 
says “Database to compact from”.  
Again, Choose the peddata.mdb file in the list of files in the left pane of the window so 
that it is put in the box directly above the left pane of the window and just under the 
words File Name as shown below. Click OK. 
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STEP 6: Now the following Window will appear. Note that the Window’s Title bar now 
says “Database to compact into” and the filenames are a lighter shade than before.   
Again, Choose the peddata.mdb file in the list of files in the left pane of the window so 
that it is put in the box directly above the left pane of the window and just under the 
words File Name as shown below. Do not use the suggested filename db1… Click OK. 

STEP 7: The following message box will appear. You must Click Yes. This will replace 
the original file with the one that has been repaired and compacted.  
 
 
 
 
 
 
 
 
 
The Repair and Compact utility will automatically close when it is finished. If you would 
like to Repair and Compact another file you just open it again and follow the same 
steps for the next file. 
 

PART IX – SHARING YOUR DATA 
You may share data with other users of E-Z PEDIGREE BASIC. Follow the steps below 

to import records from another user’s data file into your data file.  Note: This will import 

all of their records into your data file except for duplicate records. 

1. Obtain a copy of the other User’s data file (peddata.mdb) from them.   

2. Copy the file to the “C:\ezped\share” folder on your hard drive. 

3. Open the E-Z PEDIGREE BASIC program. 

 

 



 35 
 

4. From the File Menu choose “import” and follow the instructions. 

You may transfer copies of the data file on whatever media type best suits you. Or you 

may send the data file as an e-mail attachment to another user. 
 
PART X - TECHNICAL SUPPORT 
WE OFFER FREE (no charge), UNLIMITED (not limited to any specific number of calls) 
TECHNICAL SUPPORT OF THIS PROGRAM. 
 
EXCEPTION: We DO NOT support the Export and Output To options available from the program or the 
Use of your data within other applications. This is because there is such a wide range of possibilities that 
we could not explain them all. We will answer simple questions pertaining to the way your data is 
formatted within our software only. 
 
FOR QUESTION OR COMMENTS CONCERNING THIS PROGRAM, OR IDEAS FOR 
THE NEXT VERSION, PLEASE FEEL FREE TO CONTACT US. 
PH.: (217) 696-2551, FAX: (217) 696-2802,  E-mail: schapma@adams.net 
OR WRITE TO : 
CHAPMAN PET PROGRAM 
1951 HWY 61 
LORAINE, IL  62349  
   
NOTE:  We do not guarantee any regular hours of availability by Phone, but this is a 
home office and as of the writing of this book someone is usually in the office from 9:00 
AM to 3:00 PM CST on Mon., Tues., Thurs. and sometimes on Fri.. Normally If we are 
gone, on another line, or unable to answer the phone during business hours you will 
get the answering machine and be able to leave a message.  We will return your call 
ASAP! Other times you will hear a message about our hours but no incoming 
messages are recorded. We try to check our e-mail at least twice a day.  We are never 
open on Sundays.  


